Ring app help please

Ring app help. Trying to add ring app, but url goes to “backup and reset”. This is my url from kiosk browser… The “intent” is not working (com.ringapp/com.ring.launch.LaunchActivity)

Hi @Safraz_Khan , welcome to the community. Here are the intent URL for redirecting to Ring or Rapid Ring app when using the Fully Kiosk Browser.

Ring

intent:#Intent;launchFlags=0x10000000;component=com.ringapp/com.ring.launch.LaunchActivity;end

Rapid Ring

intent:#Intent;launchFlags=0x10000000;component=com.ring.answer/com.ring.answer.presentation.splash.SplashActivity;end

You can also find more app intent URLs from the help article below.

Hi. I created 2 links for each of the URL provided, when you click on each link, they both bring up the backup & reset setting.

I am following all the guides but it still not working. Any further help will be appreciated.

I just need my Ring Doorbell, which is in my Smart things app to be available to view either as a “Thing” or as a link to the App

@Safraz_Khan can you verify if you have enabled the “open URL scheme …” option in the Fully Kiosk Browser’s settings? See below.

The Open URL is enabled. See attached…

@Safraz_Khan, I just noticed the browser in your screenshot looks like an Android (Chrome) browser, instead of the Fully Kiosk Browser.
Please note that the suggested intent URL only works in the Fully Kiosk Brower. Can you try to launch the dashboard in the Fully Kiosk Brower and try it again?

1 Like

I tried in the fully kiosk browser. It says app not found for intent…
Fyi … I created a separate ring Dashboard. I then added two tiles with the links that you provided (one tile for each link) within that dashboard. I then use FKB to launch my main dashboard, all tiles functions. When I click on either of the Ring tiles that I made, I get app not found for intent… see images.

@Safraz_Khan, can you verify if either the Ring app or the Rapid Ring app is installed on this device? And if yes, can you please copy & paste the exact intent URL used in the Hyperlink resource? From the error message, it appears it is trying to load the app via intent, so my guess is either the app is not installed or there might be a typo in the intent url.

Below are the 2 intent:
Ring app:

intent:#Intent;launchFlags=0x10000000;component=com.ringapp/com.ring.launch.LaunchActivit y;end

Rapid ring app:

intent:#Intent;launchFlags=0x10000000;component=com.ring.answer/com.ring.answer.presenta tion.splash.SplashActivity;end

@Safraz_Khan, it seems there is a space in both of the intent URL. Can you verify/correct it and try it again?

James,
I corrected the space and now the URL works to call the app. It there a setting can use to keep the app in the fully kiosk browser so I can kill after completion.

@Safraz_Khan Glad to hear that you got the app hyperlink tiles working. I am not aware of a Fully Kiosk Browser settings to kill the app after switching back to Fully. Is there any issue your are currently experiencing when navigating between Fully Kiosk Browser and other apps?

I got the link working, now the app takes over the screen. I have to exit the app and then revert to FKB.
All I want to do is create a rule or something that when my Ring Door Bell is pressed, I can see the ring in my Dashboard…

This would be so easy if the Dashboard supported ring Video as a Thing

There’s a variety of Fully Kiosk settings that might help you accomplish what you’re looking for including kiosk mode, regain focus on idle, auto reload after idle, etc. I would suggest poking around the FKB settings.

They’ve also been discussed in the community - here’s a few posts that may be helpful:

Unfortunately, Ring is a closed ecosystem and they don’t expose their video feeds directly. (And their SmartThings integration doesn’t expose the video feeds outside the SmartThings mobile app either)

It probably wouldn’t hurt to voice your opinion with them. If they don’t hear the feedback from their users, they’ll probably never change. :wink:

Thanks Josh…I will play around with the FKB settings. I also found a youtube video that uses Tasker & Autovoice to intercept the ring %antouchbutton to display the ring the app then kill the process completely after sometime.

Additionally, just want to say thank you for your time and dedication to helping out all the novices like me trying to create our smart homes.

2 Likes