Ring Alarm on Sharptools

Is it possible to integrate Ring Alarm with sharptools. I would like to use Dashboard to Arm/disarm my ring alarm system. The ring app doesn’t do landscape and doesn’t have pin capabilities.

Hi @Luke_H, welcome to the community. Ring Alarm doesn’t have “public” API, and therefore is not directly supported in SharpTools. However, you may be interested to check out the following workarounds I found from my quick research:

  1. Use the SmartThings community developed Ring Alarm integrator, which requires custom smartapp and device handler, and may be a bit more work to set it up. After setup, you should be able to add the ring alarm device in SharpTools via SmartThings connection.
    https://github.com/asishrs/smartthings-ringalarmv2

  2. Create three Alexa Virtual Switches (SmartThings community developed device) in SmartThings for home, away, and disarm, and use SimpleCommand and Alexa Routine to update Ring Alarm when these Alexa Virtual Switches’ status changes. See the discussion in the SmartThings Community below. And then you can add these Alexa Virtual Switches to SharpTools via SmartThings connection.
    Ring Alarm released! (Integration project in post 13) - Devices & Integrations - SmartThings Community

    (I didn’t test because I don’t have a Ring Alarm, but from my quick play with the Alexa app, you may be able to do sync Ring Alarm using Alexa Guard, and just update Alexa Guard in the Alexa Routine without SimpleCommand.)

Please note that I am not personally recommend Simply Commands. It’s just something I found from my quick research, and I have not personally used it before. (I actually couldn’t event get my account working at this current point.)

1 Like

Thanks James. I am new to Simple Commands. I created 3 routies in simple commands (home, away, disarm). However, I don’t see them in Alexa. I enabled the Simple Command skill but I don’t now how to refresh these routines on Alexa.
Also, the Alexa virtual switch should be regular switches or momentary switches?
How do i use Alexa routine to update ring alarm when virtual switches changes status?

Also, i see 3 different alexa skills for Simple Commands. Which do i need?
Home Status
kloee for SC
Simple Command

@Luke_H, I tried to go through the Simple Commands process to get more details, but for some reason, I never got the account verification email, and tried the suggested alternative way but still no luck yet. I will have to try it again it later. :neutral_face:

You will have to say “Alexa, discover scenes” to your your Alexa device so it refresh the scene from Simple Commands. However, I did see people complain about the SC routines don’t show up immediately and had to wait for a while to try the voice command again.

Please make sure you use one of those switches that specifically developed for Alexa, like the one below. It’s not the regular Virtual Switch found in the SmartThings IDE. In Alexa Routine, you cannot use a “switch” as the trigger, and it has to be motion or contact “sensor”. So this community developed "Alexa Virtual Switch’ basically has both switch and contact capabilities, and internally maps the switch state to contact state. Ex: when the switch is turned on, it also set its contact state to open. So this Alexa Virtual Switch can be found and used in Alexa Routine, and allows you to turn it on/off in SmartThings and SharpTools.

BTW, I also look into the Alexa Guard apporach, and it appears you can only set Guard to away in Alexa Routine, but you cannot set it to home, which means this approach won’t work then. Bummer

1 Like

And just to be clear, I am not personally recommend Simple Commands, as it is just something I found from my quick research. I never had any experience with it, and am currently having a hard time to get my account created/verified. :neutral_face:

Alright, i think i have it working but it needs some tweaking. Here is what I have done so far to get it to work.
As for Simple Commands, it appears I enabled the Simple Command skill on Alexa, but Alexa couldn’t find my SC routines. I then also enabled the kloee for SC skill in Alexa. After this, it found my SC routines! As a matter of fact, when I first enabled the “Simple Command” skill, it doesn’t even show up on the list of skills I have enabled on Alexa (but when I searched for it again, it does show enabled). After enabling kloee for SC skill, the kloee for SC skill does show up on Your Skills page.
As for my Alexa Virtual switch, I used a ST app called Alexa Virtual Switch Creator which was created back in 2016 and i am not sure if it is updated or not. With these switches, Alexa did not see it as something to trigger a routine. I changed the DH of those switches to the one you listed above and now it works. Alexa can now see the switches as a trigger for an Alexa routine. (Funny thing is on the new Smartthings app, it says cannot connect to these switches).
So now I have created an Alexa routine that is triggered by the Alexa Virtual switches as a contact sensor, which then trigger the SC routines. Since I cannot test this on ST, i went straight to Shartptools io dashboard and created 3 tiles using the newly created Alexa Virtual switches. if i set them as contact sensor tile, then i can’t “press them”. So i set them as “Switch Tile” and it works! I click on Arm Home and it arms at home. I click on Disarm, and it is dismarmed.

So now here is where i need tweaking. Since I set it as a Switch Tile, it shows a light bulb. When i click on Arm Home, the light bulb lights up and stays lit. When i click on disarm, that light bulb stays lit and the Arm Home light bulb stays lit. I understand why it is the case, but is there a clever way around this? It would almost be better if we don’t light up the bulb at all if there is no way around this. What about momentary switches?

Also, can I pin protect these switches or this dashboard?

Actually, figured out the pin protect.

However, still can’t get it to work the way it should. If I arm it, it stays on. After I disarm it, I then try to arm it again. Since “arm” is already on, I have to click it once to turn it off and then again to turn it on.

I am trying with momentary switches now. i can get everything set up properly and recognized in Alexa, but it is not triggering the Alexa routine. Is there a way to make the moment last longer?

1 Like

How about creating rules in Rule Engine to turn the switches back to off to mimic the momentary button behavior? See below for the rule example.

Trigger: when arm switch changes to ‘on’
Flow: turn arm switch to off.

And create this rule for each switch.

That worked! I am still trying to tweak this though. Why does Sharptools only give me the option of a lightbulb icon for this Alexa switch? The only 2 choices for this icon is the lightbulb or a slider switch.

I am also trying to figure out a way to have the light bulb (or whatever icon used) stay on when it is armed and off when it is not. This is not the case if we are using it like a momentary switch. Any suggestions?

You should be able to choose from the full set of icons.

By default, the tile will show a light bulb for virtual switches. When you go to customize the icon, the default customization is to show a different icon for each state of the switch (eg. Switch-on for the on state, and switch-off for the off state) - each of those icon selections can be customized as you see fit.

Oh got it, thanks again. I was able to tinker to give it a better effect. I use Rule Engine (didn’t even know sharptools had its own rule engine, I thought you were talking about WebCore) to turn off Disarm and Arm Away everytime Arm Home is turned on; turn off Arm Home and Disarm when Arm Away is turned on; turn off Arm Home and Arm Away when Disarm is turned on. This way the approriate icon status and light turns on (and off) with the appropriate state.

Actually, the above will not work well as intended because, if I arm or disarm using anything outside of sharptools, it will not not update on Sharptools.

So i have to find a way to make Sharptools read the status of Home, Away or Disarm. Any suggestions?

I figured out how to have the tile show the correct status even if it was armed by another application. I created 3 more Alexa routines that checks to see whenever Ring Alarm state changed to Home, Away, or Disarmed. If it is changed to Home, it triggers or turns on the virtual switch Home, the same one i created in Smartthings to use as tiles in Sharptools. This of course will then also trigger the original Alexa routine to Arm at Home, but the redundancy doesn’t matter since you can’t arm the system if it’s already armed. I do the same for Away and Disarm. It now works perfectly. The only small little issue now is if the tile is “on”, you can inadvertently click the tile again to turn it off. This doesn’t change the alarm state but it does make the glow go away. Is there a way to make the tile not clickable while it is in the “on” state, but only while it is off?

1 Like

@Luke_H, thanks for the updates, and yes, you’d need the extra Alexa routines to update the Alexa Virtual Switches if the alarm status is changed outside SharpTools to keep them in sync both directions. Disabling the device tile’s tap action based on the certain state is not currently supported though.