Returning to sharptools, no longer have the connected hub, how to proceed?

I haven’t used Sharptools in a few years, but am beginning to look into it again. Since I last used ShapTools, I have upgraded from a C4 to a C7 and Now C8, but the old C4 is on my account. I no longer have access to it, I sold it over a year ago. What is the best way to proceed? Because of the time lapse, and evolving needs, few of the devices on the C4 are still on my system today. What is the best way to proceed? Should I do the C8 migration? or just have the old inaccessible hub removed and then set up the new one? I have tried to remove it myself, but do not seem to be able to, i get a “failed to dosconnect” error. When I tried to just add the C8 it kept getting 0Auth errors. Thanks!

Hi Clay-
Since you don’t have access to the old hub anymore, you can reach out to support and we can delete it for you.

It looks like you’ve already reached out, so you’re on the right track!

As for the C8, can you share more details about the OAuth issue you’re seeing? Are you getting a specific error message?

Edit: it looks like the Hubitat OAuth servers are having issues again. Seems to be impacting Google Assistant, Alexa, and any other integration that uses OAuth.

Hubitat OAuth Connection Issues - #2 by josh

I saw a reply come across from the associated Hubitat thread this morning from someone else having issues as well. I’m not sure why they deleted their reply though.

[Pending] OAuth Connections Down / Performance Issues - #64 by DeathJaguar - 🚧 Developers - Hubitat

1 Like

I can’t remember, I think it was something about taking too long. I’m not at home now, so I’ll have to try it again this afternoon when I’m back on my network.

I think I got it figured out. Found an article in the knowledgebase, I was trying to add pretty much everything I could, which included some hub meshed devices and groups, as well as zone motions sensors, went back, and just took a couple, and seems like it’s going to work. just need to take smaller bites rather than try to eat the whole elephant at once.

It looks like Hubitat’s OAuth servers started having issues this weekend again.

After seeing your post, I also saw a reply to the Hubitat thread about OAuth issues, so I tried from my side and I was also experiencing issues performing a fresh authorization in SharpTools and Google Home.

If you were able to get through a successful authorization, you can manage the authorizations for that hub directly within the Hubitat UI on your hub to bypass Hubitat’s OAuth servers moving forward.

From your Hubitat hub’s UI, you can go to Apps → SharpTools and adjust your selections there which communicates directly between your hub and SharpTools and bypasses the Hubitat OAuth servers. You can only use this UI after you’ve successfully authorized a hub to SharpTools as the first authorization requires going through the Hubitat OAuth flow.