[Resolved] Super Tile Icons Go Missing

AC icon missing

I’m uncertain whether this is connected, but I’ve observed some peculiar behaviors with my super tiles in the past 24 to 48 hours. I’m questioning if a back-end update might have occurred because I’ve noticed that custom images embedded within a super tile are gradually vanishing. I will share some images to illustrate what I mean. Oddly enough, the images are still present; they become visible when I attempt to edit the icon. Therefore, I’m puzzled about what’s going on.

There was an update to beta in the past ~24 hours. That being said, I’ve gone ahead and pushed an update to production which should filter out any of the events that are only intended for beta participants.

You can refresh the page in your browser to pull in the latest updates. From your SharpTools User Page, you can tap the Manage Account button under your profile image, then verify the version is 240207.xxxx or newer which includes the filter.

I’ve checked again and can confirm I’m seeing the version you mentioned. But here’s the thing: when I pop open an incognito window and head to my dashboard, I’m still running into the same glitch. And it gets quirkier—another tile is now playing hide and seek with its icons. The little person that’s usually chilling under the computer motion sensor? He just up and left :slight_smile: .

Tried it from my phone over cellular too, it’s the same story there.


Hi Bill-
Just to confirm, immediately after seeing the issue with the icon disappearing, did you try navigating directly to the User Page → Manage Account within the UI to check the version (eg. by opening the user-menu and navigating within the webapp rather than opening a new page or entering a URL)?

I just want to make sure we’re certain which version was actively being used when viewing that dashboard as sometimes browsers can be a bit wonky with how they cache things, so it’s important to navigate within the webapp.

The scenario of the beta events directly impacting production is not something I would have expected to happen in a normal scenario, but I wanted to rule them out by adding the filter. (While we tested to make sure there weren’t any trickle over events as part of the release to beta, I wanted to rule out some less common cases like sharing changes, reauthorizations, etc with the explicit filter)

Can you please send a note to support@sharptools.io with more details so I can take a closer look?

It would be helpful if you could share the following:

  • Device ID or Doc ID of the device that is configured within the Super Tile

  • If you refresh the page after the icon disappears, does the icon appear when the page reloads?

  • When the icon disappears, can you please verify what value the device is reporting as shown in the device details page within SharpTools?

    • User Page → tap ... next to location → scroll down and tap on device

The fact that you still see the icons in the configuration makes sense to me.

Keep in mind that the Super Tile icon configurations you shared are only mapping two exact states:

  • switch == 'on'
  • switch == 'off'

So if the switch value didn’t match either of those states, then there would be no matching state so the icon wouldn’t display at all. For example, if the switch was reporting as ‘unknown’ or even blank for some reason, neither of the configured states would match.

That’s why some people prefer to use states that are the opposite of each other:

  • switch == 'on' → ON icon
  • switch != 'on' → OFF icon

Thanks for the tips! It looks like my device was acting up. Even though it’s set to sync in Hubitat, it wasn’t updating its status. I didn’t restart my Hubitat hub but instead opted to install the latest update that rolled out today. After the update, my Hubitat was back in sync and everything worked fine again. So it seems the hiccup was on the Hubitat’s end, not SharpTools. My bad for sending us down the wrong path!

1 Like

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.