[Resolved] ST Reporting Samsung Hub / SimpliSafe as Away

Samsung recently updated its Hub software. Now whenever I use Tasker and ST to check the status of my alarm ST reports it as Away. I have reauthorized everything in ST, but it still reports the alarm as away (when it’s disarmed). What can I do about this? Tasker task is below in case you wanna see what I’ve been doing. When I run it, it flashes Away every time. Thanks.

-Rich Belthoff

SimpliSafe Check Away (355)
	A1: Notify [ Title:Checking SimpliSafe Status Text: Icon:null Number:0 Permanent:On Priority:3 Repeat Alert:Off LED Colour:Unset LED Rate:0 Sound File: Vibration Pattern: Category: ] 
	A2: Variable Set [ Name:%attempts To:0 Recurse Variables:Off Do Maths:Off Append:Off Max Rounding Digits:0 ] 
	A3: Variable Set [ Name:%ss_away To:false Recurse Variables:Off Do Maths:Off Append:Off Max Rounding Digits:3 ] 
	A4: Variable Add [ Name:%attempts Value:1 Wrap Around:0 ] 
	A5: Thing: Get Attribute [ Configuration:Thing: SimpliSafe Alarm
Attribute: alarm Timeout (Seconds):2 Continue Task After Error:On ] 
	A6: SHM: Get Status [ Configuration:Gets the current Smart Home Monitor status. Timeout (Seconds):15 ] 
	A7: Mode: Get Current [ Configuration:Gets the current mode and available modes. Timeout (Seconds):15 ] 
	<Do I still need to loop?>
	A8: Goto [ Type:Action Label Number:1 Label:LoopStart1 ] If [ %st_attr_value !Set & %attempts < 5 ]
	A9: Notify Cancel [ Title:Checking SimpliSafe Status Warn Not Exist:Off ] 
	A10: Flash [ Text:%st_mode Long:Off ] 
	<SET true IF SimpliSafe Away>
	A11: Variable Set [ Name:%ss_away To:true Recurse Variables:Off Do Maths:Off Append:Off Max Rounding Digits:3 ] If [ %st_attr_value ~ AWAY | %st_mode ~ Away ]
	<<b>RETURNS <font color="#1DA000">true</font> or <font color="red">false</font>>
	A12: Return [ Value:%ss_away Stop:Off ] 
	A13: Stop [ With Error:Off Task: ]

Are you verifying the Simplisafe status in SmartThings using the new Samsung SmartThings app or the SmartThings Classic app? Have you checked the SmartThings IDE to see what it’s reporting there?

I use the classic SmartThings app because the new one doesn’t support routines (or so I’m told). I checked SmartThings IDE but can’t tell in my phone the status. My SimpliSafe app reports that the alarm is off. The SmartThings app reports the alarm is off. This was working fine until about last week, which is when I think my Hub updated. I downloaded new SmartThings app and it shows SimpliSafe as off as well (best I can tell, anyway; the interface is worse than the classic app). Thoughts? Thanks.

Once you get back to a PC/tablet, I would be interested in seeing what is being reported in the SmartThings IDE. It’s possible that SmartThings has changed something with the device handler under the hood, so it’s important to see what attributes are being reported and what their values are.

Then the next step would be to put together a Minimal Working Example.

The important feature of a minimal working example is that it is as small and as simple as possible, such that it is just sufficient to demonstrate the problem, but without any additional complexity or dependencies which will make resolution harder.

I would recommend creating a simple Tasker Task. Perhaps with just two actions:

  1. Thing: Get Attribute: SimpliSafe Alarm → alarm
    Important: Use the drop-downs. Don’t use variables or variable mode as we are trying to rule out any potential factors here.

  2. Alert > Flash: %st_attr_value
    Note: Again, we are trying to rule out external factors, so we’ll use the variable which is set automatically by SharpTools

Then manually run the task and report back what you are seeing.

I worked this out. I wasn’t entirely accurate in my first post. Rather than checking SimpliSafe, I am checking the current mode of SmartThings. For some reason, Tasker reported SmartThings as Away when it wasn’t. My code checked several attributes and looped as well in case the attributes were not picked up the first time. I removed some excess code and it seems to be working now. Thanks.

1 Like