[RESOLVED] Rule Errors, fix is to reauthorize

All my rules logs from yesterday shows the same error - “Failed to send device command.”

Nothing was changed in Smarthings or Sharptools setup.

How can I fix the problem?

Thank you!

Have you tried reauthorizing your SmartThings connection?

  1. Open your SharpTools.io User Page
  2. Tap Manage Connections
  3. Select SmartThings
  4. Follow the prompts
1 Like

Morning @josh

Woke up this morning to my Dashboard not working, receiving the red pop-up message (instead of green): "error sending command".

All systems underlying the Dashboard (Shelly Smart Switches & SmartThings & Cameras) were working properly in their respective native applications.

Performed the steps you outlined above and the Dashboard instantly began working!

Thank you!!!

Thanks for the update. SmartThings was having some issues with their API yesterday and I suspect this is related to that. I’ve seen a handful of similar reports of this in the last 24 hours.

If you start having authorization issues with a particular location, performing a fresh authorization of that location is usually a good troubleshooting step!

1 Like

You’re welcome!

Worth noting that the SmartThings App DID update overnight to v1.8.09.23.

As well, the v2 & v3 Hubs did update within the last 5 days to 50.10

1 Like

Not a question, just some additional info: I just started getting the unauthorized message this afternoon. I’ve done some updates in SmartThings today (replaced some sensors) and have reauthorized several times successfully. But it looks like the authorization broke at some point though (approx. 1:58PM).

Update: Seems to be working again.

Just for the record. I had the same problem, byt solved by:

1 Like