[Resolved] Home Assistant - stuck on 'Processing'


I am trying to connect Sharptools with my HA.

I installed the Sharptools add on in HA, started it, went to the web ui, authorized, selected some lights in the ‘Authorize Entities’ page, clicked the submit button which chnaged to processing, and it just sits there forever. I’ve left it for half an hour and it’s still processing.

Have tried doing this multiple times and leaving it over an hour once, but it just sits there.

I found this topic which is the same issue in November 23: [RESOLVED] Home Assistant device synchronization problem - #2 by josh

Sharptools addin version is ‘Current version: 1.0.9’

Home Assistant versions are:

  • Core2024.1.6
  • Supervisor2024.01.1
  • Operating System11.5
  • Frontend20240104.0

Any help would be appreciated.


Small update:

If I select 0 devices/entities etc. to authorize, it does eventually finish and say successful, but it still took over 10 minutes to get to that point.

And is obviously of no help to me!

Sounds like something is definitely not working as expected. Without any devices authorized, the sync should be nearly instantaneous.

Unfortunately, my primary Home Assistant instance bit the dust last night! :person_facepalming:Let me see if I can get a quick temporary instance back up so I can take a closer look and see if I can reproduce the issue.


Thanks. I have restarted HA a few times and uninstalled/reinstalled the sharptools add in to see if that might fix it but it’s still the same.

Let me know if you need any logs and I’ll get them to you.


Just a quick update that I was able to get a test Home Assistant environment setup, but I was not able to reproduce the issue.

That being said, I pushed out an update that may address the issue based on the error messages I was seeing in the system logs. Can you give it a try again and let me know?


Thanks, this seems to have solved the issue. Managed to add 10 devices into sharptools.io with no issues!

1 Like

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.