[Resolved] Dashboard has stopped loading on FKB

Hi, all, Long time…

One of my dashboards, a rooted Kindle Fire that has been running Fully Kiosk Browser forever as a dashboard in my kitchen with no problems has suddenly stopped loading its dashboard.
I haven’t changed anything, updated anything, etc. It just stopped working today.

I have a blue bar with the hamburger on the left, my profile picture in a circle on the right, and just a dark gray screen below.

I have restarted FKB, restarted the tablet, cleared the cache, logged out and back in Sharptools, tested in and out of the beta channel for my dashboard…nothing. Just won’t load stuff. Interestingly, the other tablet in my bedroom (identical everything) is still working. I just had it reload the start URL, and it looked just like the kitchen one for a few seconds, then it got the little loading circle and loaded the dashboard quickly.

Any ideas?

Thanks,

Ricky

Sorry to hear that, Ricky! It’s great to hear from you, but I wish it was for a different reason! :wink:

Would you mind sharing some more details about the Kindle? OS versions and whatever customizations there are?

Have you tried temporarily navigating to a regular SharpTools app page? Either by enabling the navigation bar in Fully Kiosk or temporarily changing your start URL? For example, does the sharptools.io/user page load and does the list of dashboards at sharptools.io/dashboard load?

It’s a super fresh install of Fire Nexus ROM with literally nothing installed except what’s nexcessary to install Fully Kiosk Browser. It’s been working perfectly since [whenever my posts about rooting these Fires were posted–long ass time]
I’m running the latest version of FKB at this point, because I did try updating that with no result.

Yeah, so, this is the interesting part. Nothing in the sharptools site will load. When I try to load sharptools.io/user, it loads the same thing…the hamburger is there, then as soon as my profile pic shows up, the “user” disappears from the URL and it settles on the dark gray screen. I don’t know if the “user” disappearing in the URL bar is significant, because when I click reload, it does add it back and tries to reload it with “user” on the end of the URL. Everything I try to load on the sharptools site seems

Just confirmed the same with sharptools.io/dashboard. It just stops loading anything as soon as my profile pic shows up, like it’s done, and doesn’t load any of the content for the pages.

Further investigation: If I hit home, it loads my start url (the kitchen dashboard link), and settles on this hamburder-pfp page, which, when I hit reload, it is reloading sharptools.io/user. I don’t know what this means, but providing the info in case it’s relevant.

Thanks for the additional details and for testing.

Is there another internet browser installed that you can test with?

I inquired about the specific Android OS version as I wanted to test to make sure there wasn’t some sort of compatibility issue introduced at some point. But @james just tested back to Android 4.4 for me and things are working fine for him.

Another thing you could try is to back up your fully kiosk settings, then reset the fully kiosk settings to default. It does seem weird that it would have started all of a sudden though and only on one of two identical devices.

Have you double checked the OS version number and browser version numbers and all that between the two devices to make sure they are exactly the same? Just trying to narrow down where the issue could possibly be or at least rule things out.

Sorry. It’s 5.1.1
Everything is identical on these tablets, I did them at the same time on the same night, and they’ve worked perfectly ever since.

I don’t have another browser installed. They literally have The Play Store and FKB installed, and that’s it. I have confirmed that browsing randomly anywhere else on the internet works fine…type google.com, enter some random letters, search, click links, follow one to YouTube, everything loads up fine. Can’t get any site to show up in any unexpected way. How aggravating. I just loaded this thread on it. Perfectly fine. Click the home button in the action bar to load the dashboard…nothing.

1 Like

I just saw this edit. I’m not sure what this means and it’s not something I’ve seen before. :thinking:

I’m sorry. That’s a typo and an abbreviation. :joy:
I was just describing the only page that will load…“hamburger-profile picture (pfp)” as that’s the only two interface elements that will load. That’s not the name of a file or anything.

1 Like

OK. I exported my settings, uninstalled, reinstalled, and it works fine now. :crazy_face:
Thanks for the suggestion. Sorry for the fire drill (pun sorta intended now that I’ve made it).
I swear, I’ve done precisely NOTHING to this tablet…it just decided to stop working. :man_shrugging:

Thanks as always for the quick and effective help.
I’ve been kinda behind on my home automation stuff, but I’m eventually gonna be back to see what all is new. ABsolutely love my Sharptools setup.

2 Likes