Reolink Camera and Media Tiles


I decided to upgrade my old Reolink cameras with some new Reolink cameras and now I am having a hard time getting the new cameras to display properly on my dashboard.

I am using the snap URL over HTTPS per the Reolink documentation
https://(ip address)/cgi-bin/api.cgi?cmd=Snap&channel=(channel id)&rs=(any
combination of numbers and letters)&user=(user name)&password=(user password)
Doc: Reolink-url-commands.pdf - Google Drive

I see the preview of the camera when I set the URL in the create media configuration on the sharptools website. I can see the camera in the dashboard from Chrome using my computer.

When I first launch the dashboard on my dashboard tablet using Fully Kiosk, the camera loads…BUT then when the auto refresh comes, it does not load again.

Has anyone experienced this or have suggestions on what to try?

The new cameras are higher resolution. The only thing I can think of is that I might have a bandwidth problem causing the image not to load fast enough. Is there a timeout setting somewhere for Media Tiles that can be extended?

More info and answers to common questions:

  • Going to the URL used for the media tile works in Chrome and first time load on Fully Kiosk Tablet
  • I am using HTTPS and have enabled HTTPS on the camera
  • I have Fully set to ignore SSL errors
  • I have Fully set to always allow mixed content
  • One of my old cameras is still connected and works properly in the dashboard
  • The only difference between the old URL and the new URL is the IP address and login info
  • Camera IP address is reserved in DHCP


Do you mean that it works when the page first loads, but then fails after the ‘autorefresh’ interval?

If so, check out the following article - the newer cameras might be more particular about the extra URL parameters that are added for cache busting with the default ‘Force Refresh’ option:

That was it. Thank you sir!

When I turn off Force Refresh the media tile loads…but it looks like it now it never refreshes.

Do you know off hand if there is a setting in Fully to not use cache?

If you open that same camera URL in your browser and refresh the page, does the image update?

Similarly, if you preview the media item from the Manage Media screen in SharpTools, then close it and re-open it, does the image update?

It seems like some of the Reolink devices don’t like arbitrary parameters added to the URL even though that’s a common cache busting technique. The fact that the rs parameter in your sample URL indicates that it can be an arbitrary set of letters and numbers makes me wonder if that’s what they intended that for.

Would you mind sharing more details about the model numbers of your old and new cameras? And are you communicating with the new cameras directly or through a Reolink NVR or something like that?

I ended up getting one setup up in TinyCam Pro with the .jpg snap option and then using the TinyCam webserver URL in the media tile with Forced Refresh on and 1 second.

I tried RTSP and it worked but when I added a second camera to TinyCam the dashboard image was getting pixilated probably due to lack of resources on the tablet running TinyCam and the Dashboard in Fully.

I can check again, but it did not seem like the image was refreshing in the tile preview or the browser at all. It also seems like Reolink does not like any query string params after the password parameter. If I add any params after the password in the browser it breaks and I assume this is why the cache buster breaks too.

My new cameras are TrackMix POE. The old ones were RLC-420 and RLC-422. I am pretty sure they kept working because I have not updated the firmware in a few years. I saw in my searches when people updated firmware on the NVR they started having the same problem. I did get a new NVR too and I did try the Snap URL with the NVR but it did not work either. It is the same model as the old NVR, but it has a more powerful chipset for person detection. So the root cause is probably a Reolink software feature and for ‘security.’

Hopefully they add the no cache header one day and that makes the refresh work without the cache buster.

I am still testing the TinyCam work around and if it doesn’t work out, I might return the cameras or more likely, I will try setting up Home Assistant because they seem to have a solid Reolink integration. I am just not sure how motivated I am to do that right now.

1 Like