Performance Problems/Lag

I seem to be having more issues with my dashboards lately and I don’t know what has changed to cause this. Tablets are Amazon Fire HD10’s (9th and 11th gen) on latest software. Fully Kiosk for Fire HD is also on latest version (1.4.8). Hubitat is also on latest version (

What I’m noticing most is a slight lag on updating of status on the tiles (though the devices switch on/off immediately) and the green ‘Command Sent’ toasts are not clearing from the screen. There were previously some SharpTools errors in the Hubitat logs which I posted about recently but these haven’t appeared again this morning. The issues seem to be mainly first thing on a morning and I’m finding I need to use the Fully Menu > reload Start url to resolve it.

I’m having the same issues but on Fire Tablet 8. Seems to of started a couple of weeks ago when I updated Sharptools and Fully Kiosk. I’m thinking one of the two have a memory leak. Disarming my security alarm via Sharptools is no longer possible because of the enormous lag. I would guess it’s Fully Kiosk, but I don’t know.

Not sure about Fully. I was having the same issue on two Fire’s on same software - Fully 1.46 on one and 1.48 on the other but both had the issue.

I think I’m still on Fully 1.44 and haven’t seen these issues. Good to know as I might just update one tablet as a test before updating them all.

I contacted Fully Kiosk and they sent me this: [Fully Kiosk Browser Lockdown | Android Kiosk Mode App] it essentially says to update “Andriod Webview” but in my case, I needed “Amazon Fire Webview”, which I found here: Download Amazon System WebView for Android |

I have updated and I’m testing. Will let you know.

1 Like

I keep my Fire’s up to date. While running Fully seems to block updates from happening. So every week or two I shut Fully and install all available updates along with any update for Fully if available.

The problem for me is specifically the ‘command sent’ toast messages that normally clear down after 5 seconds.

Each morning if I click on any device tile, the device is responding immediately now, however the toast message remains on the screen and will not clear. So if I click 5 device tiles, they work but I have a stack of 5 ‘command sent’ toasts on the display permanently. The only way to clear them down is to ‘reload start url’ and then it works normally until the following morning. This is happening on 2 of my 3 tablets all running the same Fire and Fully software.

I have switched on logging for SharpTools app in Hubitat and no errors appear in the debug logs. I really could do with getting it resolved.

Edit: I thought this was only happening on a morning but ‘command sent’ is either staying on screen upward of 12 seconds or permanently until the dashboard url is refreshed

Thanks for sharing, John, and sorry to hear that things are getting funky with the Command Sent toasts. That’s really odd that they’re getting stuck as the timing for them disappearing is all handled internally by the ‘toast’ library that we use which hasn’t changed recently.

Can you think of anything different between the three tablets?

  • Are they all running the exact same hardware version and exact same OS / software versions?
  • Are they running the same dashboards?
  • Or can you think of anything that changed recently on the tablets? OS / software version updates or even dashboard configuration changes?

(These questions are all toward the goal of narrowing down what’s contributing to the issue so I can reproduce it and figure out what’s going on!)

I vaguely remembered someone else mentioned they had seen toasts stuck, so I searched the community and found this post by @Barry_Martin but it seemed to be specifically centered around the ‘Executed Macro’ toasts from a Super Tile. Are the toast messages you are seeing also coming from a Super Tile?

@josh The 2 affected one is 11th gen Fire HD10s, the other 9th gen and the unaffected is a 9th gen. They all have the same OS version and Fully version.

No, the 2 affected ones are very similar but not the same. They share the same layout and a number of common tiles (and SuperTiles) but each has one row (the penultimate row) that has tiles specific to that room (lights, heating)

I always keep the software up to date so every few weeks or once a month I close Fully, check for updates on both Fully and Amazon and let them install. So all three are up to date. The two with the problem are new dashboard layouts (I can PM the addresses). At first they were using the beta address but I switched the home page to the main site and then reconfigured all sub pages on them to also use the main site in case it was some beta issue.

No there are a number of SuperTiles on the dashboards (and the stuck toasts are on top of one of them), but the toasts are getting stuck even when using a normal tile such as a switch.

Another issue I’ve seen that coincides with these new dashboard layouts and the toasts problem is with a tile I have for my Garage Door. I set that tile with a confirmation prompt and a couple of times, it has got stuck between me activating the tile and the ‘Confirm Action’ popup - IE the screen blurs but the prompt doesn’t appear. That’s the reason I initially put these issues down to network lag or something.

I had a look in Fully Advanced Web Settings. The tablet without the issue (9th gen) is running the Webview version that you have detailed. The two that have the issue (one 9th, one 11th gen) are running ‘Webview’

I’m not sure why the webview version hasn’t updated on the other two. I’ve updated one of the problem ones to see if it fixes the issue. The tablet showed ‘app not installed’ but checking again in Fully, the webview version is showing the new version now.

Edit: The problem remains on both tablets after updating webview on just one of them

Think I need an update as well.
Everything runs quite smoothly, but I have a second dashboard tile and 2 tiles which direct to the other dashboard, all 3 are very slow to respond.
When I tap a light or rule tile, it’s not what I’d call fast, but it’s within acceptable time, like a second or 2.
For the second dashboard to load it can take upto 10 seconds before it changes over. Once it’s started to load, everything moves into place swiftly and simply works like the other dashboard.

I’m no further forward. The ‘command sent’ messages sticking aren’t the end of the world as I can remove them with css that I found in another thread. But if they’re an indication of something not running well I’d rather know. Normal commands on switch tiles etc are quite snappy. I’ve an issue with a tile that requires confirmation, which sometimes gets stuck as the screen de focusses and the confirmation pop up doesn’t appear. The other thing I notice is that url tiles can be slow to load. This happens after a period of time. What I mean by that is that if I reload the dashboard page now, all will work well, but if I then don’t touch the dash for some hours, that lagginess will start to affect it until I reload again. It’s as though the idle period is somehow causing things to slow.

What I’ve tried so far:

  • Install updates on Fire HDs
  • Install latest Webview version
  • Update Fully to latest version
  • Shutdown/restart Fire HDs
  • Re point all dashboards to the non beta site
  • Click the ‘Privacy Check’ in Fully and delete all history and cache

Remaining things I’ll try:

  • Reload older version of Fully on one of the affected tablets (1.48 currently, will try 1.46)
  • Factory reset Fire HD
  • Remove ALL SuperTiles from an affected dashboard - there are more SuperTiles on the affected dashboards
  • Implement the Fully ‘Auto Reload on Idle’ and set to 1 hour (3600). Perhaps it’s as simple as automating the refresh to avoid the problems.
  • Put a claw hammer through the centre of the Fire HD screen (a last resort and I hope something else fixes it)

I am anxious to hear the results as I have the same issues, mostly with lagging, on my Fire tablets as well.

If I fix it with the claw hammer I’ll post a YouTube video!

Not a great start. I noticed that the 1.48 version filename when downloaded is not appended with ‘-fire’ (though I’m pretty sure I selected the version specifically for the Fire). Anyways the tablet does not allow downgrade to a previous version and just shows ‘app not installed’ so I guess I’ll have to uninstall Fully to put an earlier version on.

Edit: The 1.48 version is both for Android and Fire - ether is no Fire specific version

I’ve factory reset one of the affected tablets (by booting into the maintenance menu and wiping everything). Once reset I’ve programmed it back up, this time not accepting any Fire updates (as recommended on the Fully website). This has reset the Webview to version 96. The toast messages remaining on screen issue remains after a period of being left idle.

Thanks for the update, John, and sorry to hear that the changes didn’t help.

As you alluded to in a previous message, I wonder if there’s something about the account or content in the account/dashboard contributing to the issue. Two things I might suggest trying:

  1. Create a separate free SharpTools account and share just that dashboard to the account. Then use that account to display the dashboard.
  2. Try creating a simplified test dashboard - maybe with just a handful of switches that you primarily use. If the issue doesn’t exist there, we can start layering in more tiles/features and see if there’s something contributing to the issue.

Hi Josh. I think I’ve tried just about everything on my list except the claw hammer! On the one I factory reset, I’ve also uninstalled Fully 1.48 and replaced it with 1.46 but it’s still happening. The toasts stick, I refresh the page, they clear, then all subsequent ‘command sent’ toasts appear and clear after 5 seconds. A few hours later the issue comes back.

It’s probably easiest to try your second option first. The dashboards that are causing the issue are very similar, bar two super tiles, to how they were before the issue started. I’ll duplicate the dash, delete the super tiles and see if that makes a difference.

1 Like