Open/close garage door via MyQ

I’m surprised not to see this asked/answered already. Or maybe I’m not as good a sleuth as I think I am.

Question is: how can I open/close a Chamberlain (MyQ) controlled garage door. As I’m prepping to head out, and about to set the alarm… or as I’m getting ready for bed… and I see the garage door is still open… I obviously want to close it, and asking for that via my ST dashboard seems like an obvious common want.

I know Chamberlain and MyQ are concerned with closing the door without having your eyes on it, but they enable that, and have actions (flashing light and I think some alert sound) to try to preclude any badness that can come from such a blind close.

Hi @Scott_Farnsworth, what device handler are you using for your myQ garage door? And can you post a screenshot of your myQ garage tile? (I assume you wanted to control it over the dashboard, instead of rule engine, but please correct me if I am wrong.)

Hi James, thanks for the quick response and sorry for the tardy answer to your questions.

I don’t have myQ in my SharpTools dashboard yet, and thus my question. I don’t have it even in my Hubitat. I recalling looking/trying to do that a while back and it did not seem to be easy/straightforward. I guess I was thinking maybe SharpTools possibly might have a direct connection to myQ.

Maybe the answer to my Qs is… “if you haven’t gotten myQ working from your hub (Hubitat) then you can’t control your garage door via Sharp Tools”. Sound about right?

As my first step should I should go back and re-investigate how to open/close my myQ controlled garage door via my Hubitat hub? And after that controlling via Sharp Tools will be obvious and easy.



That’s right. SharpTools doesn’t directly connect with myQ at this point, so you will need to connect myQ to the hub first, and expose it to SharpTools dashboard/rule from there.

James… OK… good news/bad news… I did get the myQ accessible in my HE. I can use that and click on the ‘Open door’ and ‘Close door’ button. The sad part is that when I now got to add that device to my Sharp Tools App, the device isn’t there. I can not find it. I’ve added this question to the Hubitat community to ask for help. If you’ve heard of this and have an idea how to fix, I’m all ears. Note that it’s a ‘master slave’ arrangement on two HE’s, but ideally that shouldn’t matter.


Here’s what I posted in the Hubitat community:

I was successful at setting up the myQ lite app (I think I have that name right). It’s working perfectly.

(It was a bit tricky for me… I have two HEs and I first set it up on my main HE… didn’t work… I then set it up on the HE where the myQ is… working great… even via mesh to my main HE)

Therein lies the rub… next step is to make the “Open door/Close door” controls show up on my Sharp Tools dashboard. In the Sharp Tools app I don’t see the Garage Door Opener. Lots of other devices are accessible there from the remote HE, but not the Garage Door Opener.


@Scott_Farnsworth, you can follow the steps in the post below to add the unrecognized thing in Hubitat as long as the device handler implements at least Actuator or Sensor capability.

You’ll want the version of the Hubitat MyQ integration which requires a tilt sensor. The author of the MyQ integration strongly recommends the tilt sensor, and I would too.

1 Like

Hey Josh, thanks to you and James for your tireless support. You have a great product.

You say “You’ll want the version of the Hubitat MyQ integration which requires a tilt sensor.”

That makes good sense. I gather the sensor is what tells the app that the door is open or closed (and thus tells the app what to do when the button is pushed).

I uninstalled the ‘no sensor’ version and installed the ‘with sensor’ version and… in HE, in the Device page for the Door opener, it shows the correct status (door open/door closed) and the ‘open’ and ‘close’ buttons work perfectly (yay!).

Alas it doesn’t seem to work on either the Hubitat dashboard nor on the SharpTools (boo!).


Wait… wait… I went back to my HE for something else (Rachio) and I noticed the share from HE to ST said the Garage Door Opener was OFFLINE. There was another one that wasn’t OFFLINE so I shared that an presto-change-o, IT’S Working! (Yay!)

Thanks again for a great product and for your’alls help.


Thanks for the update! Glad to hear it’s all sorted out! :smiley:

Hey Josh and James,

Long time (which must mean things are going well, eh?)

Things are going well with one exception. I’ve tried over and over to solve it myself, but to no avail. :frowning: Thus time to throw myself at you’alls mercy :slight_smile:

Per above, I have two Hubitat Elevations, one in the garage and the ‘main one’ in the house. They’re ‘meshed’. I have a Chamberlain garage door opener and MyQ.

Thanks to your help all was working well. I had the icon on my ST dashboard. It was red with the door showing open when open. It was green with the door showing closed when closed. I could tap that tile and I’d be prompted to confirm and the door would then open (if closed) or close (if open). All was good. Well, almost (you KNEW this was coming, eh?).

It worked perfectly, most of the time. The culprit? The associated contact switch that was helping MyQ to know the state of the garage door. It passed along the right information most of the time. But, of course, “most of the time” isn’t what most of us are aiming for, especially for a garage door.

Hence I swapped out the contact sensor for a tilt sensor. It’s a Z-wave Plus Gold Plated Reliability Garage Door Tilt Sensor, White (TILT-ZWAVE2.5-ECO). Works great. In Hubitat, both the Garage and main/house ones, it shows the correct state, including in the device managed by MyQ. On the Hubitat dashboard all is well.

The problem? On my ST dashboard the state is “open” 100% of the time. I’ve removed and re-added it in ST many times. I’ve removed and re-added it in the mesh many times. I’ve removed and re-added the device via MyQ many times. I think I’ve exhausted my ability to diagnose the problem. Thus I’m throwing myself at the mercy of the ST Gods.

Sorry if this has been ‘asked and answered’. Sorry for the long post. And thanks in advance (for any help you can pass my way).


Most of the MyQ integrations I’ve seen have some form of ‘virtual’ garage door that is backed by a physical contact/tilt sensor connected to your hub. It sounds like you changed out the physical contact sensor which helps support the MyQ garage door device, right?

Which device is reporting open in SharpTools?

One helpful troubleshooting tool is to check the reported device details directly rather than in your dashboard. From your User Page, you can tap the ... next to a location, then scroll down and tap a device to view it’s details.

I would double check that the same device is being compared between SharpTools and Hubitat as well. From the SharpTools device details screen, flip the Advanced toggle in the top-right corner on and make the same “Thing ID” for the same Hub ID / Location ID is being compared.

Not directly related to your MyQ, but an alternative for consideration for others who might be reading:
Shelly1 Relay (and you can still use a Tilt Or Door/Window sensor) -
Relay -
I also have the door/window sensors, but have not used on the garage door - - note this is also a tilt sensor.
You can power the Shelly from either 110 - 240V AC or from 12V (I have used an old 12V Amazon Echo Dot adapter for one of my Shelly 1’s)
And you can program the Relay to give a momentary output.
I just did a quick look to see if anyone had already done a guide on this and found this one which pretty much covers it
Make Your Own Smart Garage Door Opener for $15 - HomeTechHacker
I use SmartThings so Shelly integration with that and Sharptools is straight forward. - no hub required either

Thanks guys, absolutely I can get you all that information. Right now I’m out door working but once I’m back inside I will pull it all together and get it off to you. Thanks so much!

I don’t know if you’d call it ‘physical’. It was a zwave magnetic relay (contact) switch. The magnet came close to the contact switch when the door closed. I swapped that out for the tilt switch. They’re both zwave and they both report ‘open’ or ‘closed’. In ST I see the tilt switch and it says the door is closed. The MyQ says it’s open.

Hm, OK I when there and flipped the Advanced toggle and see the Thing ID. Not sure I follow what to compare that against.

James reached out by email. Will provide more details there (to support).



Whoops… I think a mention from James about the SharpTools app in Hubitat may have fixed it. I went back and double checked that the new MyQ ‘garage door’ instance was properly listed in the ST app in HE. Once it was all seems to work properly. Thanks! [must keep that in mind]. I want to dig more into this ‘Thing ID’ of which Josh spoke, but for now I think I’m good. THANKS GUYS!