New device attributes greyed out


Added a new sensor today to Hubitat and it doesn’t work in SharpTools.
Sensor works normally in Hubitat and for example in WebCore.
I have same exact other device in use and it works in SharpTools too (except Tamper for some reason?)

This new shows attributes as grey.

Tried to:

  • refresh app settings in Hubitat
  • reboot hubitat
  • refresh dashboard webpages

What next?

Managed to get one attribute alive by doing authorization from SharpTools side

Temperature and tamper still not usable. Tamper I do not mind but temperature is needed. Is there known problems with authorization when it is done from the hub side?

Do you have these attributes added to a dashboard somewhere?

The attributes being greyed out in your screenshot indicates that they are authorized but there isn’t an event subscriptions setup for them which typically means they haven’t been used in a dashboard or rule yet.

It is just really slow for enabling these attributes for SharpTools… but finally temperature was there too.

Both contact and temperature was added at the beginning to supertile and supertile was added to dashboard. Temperature took over 2hours till it started to work. Do not know why.

Thanks for the update. If it happens again, you can try refreshing the page showing the dashboard with those device attributes. When a dashboard page is refreshed, it kicks off a health check behind the scenes to make sure the relevant event subscriptions are setup.

And if that doesn’t help, make sure logging is enabled in your hub/smartapp and grab a snippet of the logs when you add the attribute to a dashboard and refresh the page.

1 Like