Mobile phone presence device smartthings

Hi, Now that the latest updates have been rolled out on Smartthings could someone tell me the cheapest, easiest way to get two mobile phones working as presence sensors? I just want the tile on Sharptools to light up when they are present and to go dark when they are out of range so I can see when people are home.

You need to have the phone set up as a presence sensor in Smartthings, then make sure it is shared with Sharptools. I flipped mine so it doesn’t light up when I’m home.

It only shows whatever the status is in Smartthings. I saw that you have a thread there to figure out why yours isn’t updating so hopefully you’ll get it updating from there.


1 Like

I’ve done this but it doesn’t show the phones as being away because I am unable to set the ifttt in smartthings because the phones do not show as available devices in my app. I have the latest update on the app running

Ahhh. I don’t use IFTTT. I only use the Smartthings phone presence integration.

That’s not available in the latest update :sob:

Hmmm. I’m using it right now. IT updates regularly. Maybe because I added it long ago?

Maybe it’s because I don’t have a hub, just the app on my phones?

maybe. Do you have the app on each phone. If so, go into Setting (three bar menu at the bottom of the app) on each phone you want presence detected on, then the gear in the upper right hand corner. From there you’ll find “Get your location from this phone.” Make sure it is turned on.

If the other phones aren’t connected to the app, go to the app home page, select the three dots, then manage home. Select Invte Members and invite each of the people that you want to add. Note that they will get complete control at that point.

When you went through the 3 steps I suggested in the ST thread, did it show a home location in the geoloation section?

1 Like

Yep, I’ve done all of that. I can see the phones on sharptools, it just doesn’t update the presence. I’d like to respond on the smarttthings forum but I’m unable to do it due to being new to the community. I’ll just have to wait. Thanks for your help.

1 Like

Have you tried checking your app permissions? Set it to “Always” instead of when "App is in Use?

Sorry it’s taken me so long to respond. Yes it was set to always. I changed the location of one of my phones on the app manually and after a few days it updated as being away. After that I set the proper location and it showed as present. Hopefully it will work properly now. I still need to do it with the other phone.