Local website won’t open in modal

I’m trying to launch a local dashboard (hifiberry.local)in a modal when tapping a hyperlink tile. The link opens on other devices but Sharptools won’t open it - just loads forever. Is there a trick to these?

Browsers will block loading an insecure URL on a page that is secure, so it would need to be served over HTTPS if you want it to open in a modal. Otherwise you would need to use the ‘Open in Same Window’ or ‘Open in New Window’ option.

I tried the other options and it fails, as well. Can I force it?

edit: same window option works, just not the other two. ideally i’d like it to open in a modal so i can just close it and go back to the dashboard.

edit 2: it only works on browser and apple devices - not working on my fire tablet with FK, which is the issue.

Same Window and New Window should function similarly… just that the latter opens a new tab/window. It’s just the modal that has security restrictions from the browser.

If ‘Open in Same Window’ isn’t working in Fully Kiosk Browser (but is working on other devices) then it sounds more like a networking issue. Does that page work when accessed from another browser on that same tablet or when it’s set as the start URL for Fully Kiosk Browser

Depends on the browser. It’s generally not recommended as it’s usually a blanket setting that effects all resources that you can load.

In Chrome, you can adjust the Mixed Content Settings to allow insecure content.

Similarly, in Fully Kiosk Browser you can adjust the Settings → Advanced Web Settings → Mixed Content Mode = Always Allow

Thanks, I’ll mess with those settings and see if it loads as the start URL. I’m assuming it’s because i’d the .local so i’ll try the IP as well.

1 Like

Update: I couldn’t get it to load with the updated settings and I couldnt find a unique IP address.

Android based devices, including Fire tablets, don’t play well with the server.local style addresses. For example, on my computer I can access http://homeassistant.local:8123, but on my Android based devices I have to access it from the IP address that I’ve reserved from my router (eg.

Have you tried assigning a static IP address to the device? Most modern routers have some way of assigning static IP reservations now.

When I do a custom tile with the IP, I just get a preview of the Sharptools website.

I also tried a static IP, with the same result.

Make sure to use the full URL (eg. include the http:// in the custom tile editor) otherwise your browser is likely trying to display a relative path which is why it’s showing the SharpTools Developer Tools within the preview. :slight_smile: