Issued adding dashboards - menu keeps collapsing

I have started having an issue adding dashboard tiles recently. I click Add then select dashboard. It opens up the list of dashboards to select. Then as I scroll through the dashboards it collapses again. This is happening on Mac Safari, Mac Chrome, and Windows Chrome so thinking it is something with my account?
Recording 2022-06-11 at 09.50.41

Tried restarting the browser, etc. Any thoughts? Thanks.

That’s a new one that I’ve never seen before. And it’s really interesting that it applies across Safari and Chrome since they use different rendering engines and your browser plugins would likely be separate / different between them – both are things I would suspect as potential issues since nothing related to this changed recently and I haven’t seen any other reports of it.

If you use the search feature at the top of the Add Item screen, do you have any issues with things collapsing?

It does appear to be an intermittent issue and it may be related to memory management on the Mac. A reboot seems to clear it out. Not a big deal but was just posting to see if anyone else had seen it.

This was happening to me yesterday or the day before while editing one of my dashboards. Add > Select tile type (thing, url etc) > the list appears and would not collapse if left, but as soon as I use the trackpad to move the pointer the desired line, it would collapse. It was very hit and miss as I tried to move the pointer faster or slower to land on what I wanted before the menu collapsed. For reference I’m using MacBook Pro 2021, the inbuilt trackpad and Safari.

Thanks for the additional details.

We test on Mac OS devices through our cloud testing suite and weren’t able to reproduce there, but that’s an interesting insight about the potential implication of the trackpad itself. I’ll see if I can get my hands on some physical devices to test with.

I’ll see if I can replicate it again. If I can I can easily plug in an external mouse to see if the behaviour is the same.

1 Like

@josh I’ve just tried it again and for me the issue can be replicated by:

  • putting a dashboard into edit
  • click +
  • expand the ‘Dashboards’ section
  • move the cursor down

This causes it to collapse, often before you’re able to click on a Dashboard entry.

Strangely it only happens when trying to add a Dashboard link. I cannot get it to fail in the same way, if I try and add ‘Media’, ‘Thing’ or ‘Hyperlink’ (my previous comment June 17th was made from memory, so was inaccurate)

1 Like

Were you able to connect an external mouse and still able to reproduce?

I just tried with our cloud testing suite and wasn’t able to reproduce with the Dashboards collection, so either there’s a detail/nuance I haven’t uncovered yet or perhaps the physical trackpad does have some impact?

Edit: For reference, this was on macOS Monterrey 12.1 with Safari 15. Same on macOS Big Sur 11.6 with Safari 15 or Safari 14.

Not tried yet but I’ll dig one out now and report back

1 Like

Thanks! I’d also be curious if it’s reproducible on a brand new, blank dashboard. I tried on a variety of dashboards across our cloud testing suite, but couldn’t trigger it. I’m sure there’s some missing factor though!

So I can get it to happen with a USB mouse as well. I was wondering if it was happening as I have a long list of Dashboards but obviously there is a way longer list of ‘Things’ and it doesn’t happen there. I’ll start a new empty dashboard from scratch…

I got it to collapse once or twice on a new dashboard but then it appeared to work normally. When I went back an existing dash that started behaving normally as well - I’m flummoxed!

1 Like

For what it is worth - when I run into this issue I shutdown Safari and restart it. Seems to clear up immediately. Don’t know what that means but thought I would offer it up.


Hi @simon and @John_Williamson – just wanted to provide an update that I ordered a Macbook for testing and was able to reproduce the issue. Now I just need to get my dev tools setup so I can look into what’s going on here.

I didn’t want you guys to think I left you hanging here… it just took a few weeks to get the new Macbook Air M2!


Josh if you took a fancy to the new MacBook Air with the M2 processor, it’s all good. But that sounds like an excuse I’d give my wife: “What on earth do you need another Mac for?” “Ermmmm - I need it for testing, it’s an essential spend” :wink:

1 Like

I just got my MacBook Air M2 yesterday. Love the keyboard over the M1 Air. Not quite as fast as my Studio but very happy with it.