Hyperlink Tile vs 'Open Hyperlink' Action

I’m doing some more messing around with YouTube embeds on a dashboard and have hit an issue. I wanted to have a dashboard with TV channel logos on for live tv feeds from YouTube. So I’ve:

1 - Downloaded the channel icons
2 - Loaded them into a folder on the Fire HD
3 - Created a media tile that points to the logo location (https://localhost/storage/emulated/0/logos/skynews.jpeg)
4 - Set the action on tap to open the SkyNews feed (https://www.youtube.com/embed/9Auq9mYxFEE?autoplay=1&modestbranding=1)

The channel icon tile on the dashboard displays the logo correctly, however when I tap the tile, YouTube gives an error and will not play the stream - in modal, in same window or in new window.

If however I create a hyperlink tile that points to the same url (https://www.youtube.com/embed/9Auq9mYxFEE?autoplay=1&modestbranding=1), that will work fine.

Why would the hyperlink tile work but the ‘open hyperlink’ action on tap fail with the same url? Obviously I could just use hyperlink tiles but it doesn’t look anywhere near as slick as using the channel icon.

What kind of error are you getting? If you’re on a computer, you might also open the Browser Console (F12) to see if there are any specific error messages.

I just tried with a Media Tile and the Open Hyperlink action with your URL worked as expected for me with the various different Link Actions (Modal, Same Window, New Window):


It’s a YouTube generated playback error. A bit more messing around and I’ve found the issue seems to be caused by the media tile address being local on the Fire. I just tried hosting one of the tiles on imgur as you’ve detailed in a post regarding a jukebox dash. If I do that there’s no error and it plays.

So a remotely hosted image file as the target for the media tile, displays the image and the video will play using the YouTube url for the action on tap. A locally hosted image file as the target for the media tile, displays the image but YouTube then block the action. I’m confused as to why.


I’ve just tried again and now it works using the locally hosted image as well. I’ve not a clue why it’s begun to work