Hubitat Mode Help Needed


#1

Problem: When I try and select “night time” a mode I added to arm my HSM for armed-home and “morning” to disarm the system when I wake up nothing happens at all the sharptools interface doesn’t even say command sent. All of the other modes can be selected I have Day, Home, Away.

What I have done: I have totally blown away the modes that won’t work in Hubitat and re-added them - didn’t work.
I have deleted Mode Manager in Hubitat and re loaded it - Didn’t work
I re-booted my hub in between all of the above changes as well
I have changed the name of the modes and then re-set up to see if a different name would work - Didn’t
I have disconnected and re-connected Sharptools to Hubitat multiple times.
I have deleted Sharptools from Hubitat and re loaded it as well - didn’t work

I am running the latest version of Hubitat and I have used Chrome browser on a Windows 7 PC as well as a Mac Book Pro running Mohave and using Safari. Mobile device would be iPhone 8 Safari. None of these platforms seem to matter it simply doesn’t work.

I noticed that when you authorize devices in sharptools there is no option to select the HSM or Mode options??? Might have been overlooked by the developers.

I can easily go along fine with these buttons not working but at this point I want to fix it just because it is bothering me.

Thanks for any help


#2

Thanks for the really well written problem report and sorry to hear that the changing the custom night time mode isn’t working as expected.

What Hubitat Hub platform version are you running? We just tested on 2.0.0.104 to see if we could reproduce and we were able to use all of the default built-in modes as well as some custom modes.

The SharpTools HE app will automatically authorize HSM and Mode control (including all built-in and custom modes).

Edit: And we created a custom Mode called ‘Night Time’ and tried that and it worked as well. Have you watched your Hubitat logs while you tried to run the Night Time mode from SharpTools to see if there are any error messages?


#3

FYI, I just updated Hubitat to the latest (2.0.1.110), and couldn’t reproduce the same issue. Custom mode name and exact “Night Time” mode name were tested with no issue. It’s interesting as it sounds like the default modes work for @Shaun_Dominguez, but only the custom ones are having issues?


#4

I will get my exact running Hubitat version when I get home from work. I don’t know this for sure because I didn’t have my hub very long before the new 2.0 update came out but I think it may have been something with that update that threw it off but again that is just a far guess. It does in fact seem like only the default modes are working. I am able to switch to any mode by using the Hubitat Dashboard so that is why I suspect it could be an error with Sharpthings. I will get that Hubitat version and check the logs later this evening.

Thanks


#5

Ok so I updated the Hub to 2.0.1.110 and tested again to see if the new update may have miraculously fixed everything and of course it did not. So I changed the name of my Night Time Mode to just Night because that’s what the default installed mode is called and low and behold it is now controllable via sharpthings. So I have an additional mode called Morning that was custom and it will still not work. I looked at the logs and here is the error:

image

I know absolutely nothing about how to code so I would need some help correcting this issue if possible. Thanks again


#6

What does the log line before that say? If it can’t find the mode, there should be a line like:

Requested mode of {mode} was not found

I’d be curious what the log says and if it matches the mode name set in Hubitat.

PS. We are talking about SharpTools, right. :grinning:


#7

This is the log from Hubitat showing the sharp tools interaction. I don’t know if there is a way to bring up a log in Sharptools but if there is I can pull that up if you tell me how.


#8

Thanks for the additional logs. Is the real mode in Hubitat exactly called Morning as displayed in the log? I’ll try a few more custom mode variations tomorrow to see if I can reproduce.


#9

Yes it’s Morning in Hubitat.