Hubitat Echo Speaks

Is anyone having issues with Echo Speaks using Hubitat? I have my dashboard with ES setup using rules to change volume, play songs etc. Around 50% of the time I’m getting: error sending command. I had this exact setup with ST before they blocked it and had no issues. Is anyone else experiencing this?

Hi @Declan, are you getting the error for Echo Speaks devices only or other devices as well? and the “error sending command” error should be related to a device tile, instead of rule tiles, or can you please help me understand your setup a bit? (Thought you were using “rule” to control Echo Speaks devices as mentioned in your post?)

Hi James, sorry I should have explained a bit better. I am only getting this error for echo speaks devices.

I created rules for each command eg volume, songs, mute etc and then added tiles to a dash board to run rules, along with the music player tile. I get the error even when for example using the music player tile to start or stop a song. I’m guessing this might be a Hubitat issue as I’ve had the exact setup with SmartThings and had no issues. Just wondering if others came across this issue? I tried reinstalling ES but same results.

@Declan, thanks for the additional details. I would thought the issue might be related to the Hubitat cloud relay or the hub itself but it doesn’t make sense to me you experienced this issue specifically for Echo Speaks devices only. Can you please send the device’s id to support@sharptools.io and I can check if there’s any error in the system log? You can find the device id by going to the User Page, tap ... next to your location in the “Authorized Locations” section, click on the specific Echo Speaks device and the id is the last part of the URL. Ex:

https://sharptools.io/user/thing/uJxfDDVDe8qLNRummhug

Hi James, apologies for the late reply. I’ve finally had sometime to go look at this. I migrated over some lights from ST to Hubitat but I am having issues. It’s as if there is a communication issue between Hibitat and Sharptools. Sometimes it works, sometimes it doesn’t but works every time in the Hubitat app. If I sign in to authorize Hubitat again in Sharptools the lights etc work instantly. Is there a setting I need to use to stop timing out? I was wrong when I stated it was only Echo Speaks because my lights where still using the ST hub. Thanks

@Declan thanks for the updates. What type of lights are they? And when you control things, did you see the events sent over SharpTools.io in the log?

I’m using Phillips Hue with the built in app in Hubitat. It seems like I can’t / don’t have my hub linked properly to SharpTools? Is there specific settings? When I re authorized my hub it works for a while and then seems like it times out? Nothing works via my dash board but will work in the Hubitat app…

Sometimes when I try to sign in to re authorize I get this but the Hub is online and I can login via my web browser?

Thanks for the screenshot. The “Hub is not responding, please verify it is running and connected to the internet” message is coming straight from the Hubitat authorization servers, so Hubitat thinks your hub is offline or can’t be communicated with. That likely explains why you have intermittent difficulty with device control as if Hubitat can’t talk to the hub, SharpTools can’t either.

The most common cause of this is the hub getting bogged down and getting disconnected from the Hubitat Cloud Relay. And the most common fix for this is to reboot the hub, wait several minutes for things to calm down, then try to reauthorize again. That being said, if your hub frequently gets exhibits this issue, it’s likely indication of a bigger issue (eg. something causing the hub to get bogged down).

Thanks Josh, I tried that a few times before but it still seems to time out after a few minutes. Tried again just now and worked perfect for few minutes, could control everything, but has stopped again :frowning:

Is there any settings I can use to help this or am I out of luck?

I would start by taking a look at what all is on the hub. Certain community developed drivers and apps can put a heavy load on the hub and cause it to bog down.

Unfortunately, Echo Speaks is one of those integrations that can put a heavy load on the hub. If I remember correctly, Tony recently put some effort into making Echo Speaks a bit more lightweight on Hubitat, so you might double check that.

You could also try temporarily disabling all community integrations to see if things stabilize… then enable them one-by-one until you find the culprit.

Thanks, looks like it’s Echo Speaks then as it was doing it when only it was installed. I’ll reset the hub and try with just the my lights. Thanks!