HTTP GET Fail in Tasker

I set up HTTP rules in SharpTools that are triggered by Tasker. I set this up to open my garage door when I arrive and unlock my kitchen. This worked fine yesterday. Today I get errors with all my HTTP calls. I’ve tried several times. Anyone know what the error is in the screen shot and how to fix it? Thanks.

We pushed an update around 15:38 CDT that introduced the issue for HTTP Triggers which didn’t have a Content-Type associated with them. A fix was deployed around 16:26 CDT to resolve it. My apologies for the inconvenience!

OK. I thought it might be something like that. I guess I shouldn’t have come home a bit earlier today. Ha. All worked well just now. Could I have avoided this if I had a Content-Type? If so, what is a Content-Type? Thanks.

My apologies for the inconvenience. :flushed:

Technically, yes, but you shouldn’t have needed it at all. It was a bug on our part.

If you *really* want to know about the technical background... (tap to expand)

The Content-Type is a way for something like Tasker to say what type of data it’s sending over with the request. In this case, it’s used whenever someone makes an HTTP POST request to a webhook. So back to the Tasker example, you’re using an HTTP GET request which is usually used to read data whereas an HTTP POST request is used to write data. With a GET (read), there’s no extra data being sent across other than the URL, whereas with a POST you can attach additional data to the message.

Hence why it was a bug that the code tried to access the Content Type in certain cases where no content type would ever be included. :slight_smile: