How do I get Blue Iris to work in SharpTools?

Hi. I’ve seen a few posts were folks reference getting Blue Iris working in a media tile but this seems really complex.

I want to setup the sharptools as a dashboard to be used on either a fire tablet or an ipad. I just want the camera’s to be available on the dashboard on the tablet locally in my house, I don’t need to see them outside my home.

Is there an easy way to do this? I’ve tried to create two media tiles but neither work and i have no idea how to delete them.


1 Like

What is the link you’re trying to use?

If it’s only local, you should be able to use your Blue Iris machine’s IP-address, including the port, mjpg, short name of the camera, video.jpg.

Are you using fully kiosk? Because the android webview has been updated a while ago and will not show insecure content. You can get around this by deleting the webview updates on the tablet.
You will also need to enable to show mixed content in Fully Kiosk settings.

If you’re just using a webpage, there shouldn’t be an issue.

Hi. Thanks for your reply. My link is:

This brings me me to a screen where i can see all of my cameras. Not using this in kiosk mode.

Can i setup a tile for this so it displays my cameras? or do i need to have a “clickable link” where it would open this view in another window?

You could indeed use that as a clickable link to view it, but ui3 is the webinterface, most people want a permanent view of the camera on a tile, not the full interface.

You can try the link I suggested above in a media tile for direct viewing.

Does that site allow embedding within a SharpTools dashboard? Either opening the hyperlink as a ‘Modal’ or using a Custom Tile to embed the URL directly?

Keep in mind that Chromium based browsers (which is most modern web browsers) will block ‘mixed content’ by default. Since the page is not using SSL, you might need to follow some of the tricks in the following post:

Pay particular attention to the note about Chromium 111 and newer browsers. Unfortunately, Google introduced a frustrating bug where the ‘Allow Insecure Content’ flag is broken for sites loaded by IP address. One workaround is to use one of the wildcard DNS sites like with your URL. In your example, that might be:

Group Streams

Another really cool feature of Blue Iris is the ability to use ‘Groups’. You can add cameras to any mix of groups that you’d like and then you can access a group stream from Blue Iris.

While this adds a bit of processing overhead to your Blue Iris server, I found it to be a really helpful feature where I could add 4 of my cameras into a group and get a single 2x2 grid stream on my dashboard rather than 4 individual streams.

(It’s been a long time since I’ve played with Blue Iris, so I can’t remember the exact steps on this, but I think it’s just the ‘short name’ of your group being used in place of the short name of your camera in one of the stream URLs)

1 Like

I came across this while looking into this:

Is a similar application viable? If so, what parts would we need to adjust, etc.

Thank you for your time.

That’s the approach I was referring to above with using a Custom Tile (immediately above your reply).

In the blog example, they are using a valid SSL cert port forwarding, and domains… but if you just want to view locally, you could probably used the mixed content setting mentioned in my post above.

A key thing they missed in their post is you must enable iframe support within Blue Iris web server settings. I actually just bought another Windows and Blue Iris license so I could spin up a VM to test this, so I’ll grab some screenshots when I get back to a PC.

Edit: Here’s the screenshots. I set my Blue Iris authentication to Non-LAN only as it seemed like Blue Iris had some quirks around the headers it was sending which would break things when embedded.

And the Allow <iframe> tags must be checked as well.

From there, I already had Insecure Content set to allow within Chrome, so I just used the URL and it worked as expected:

(Personally, I use Caddy2 as a reverse proxy along with an AdGuard DNS rewrite entry for an internal domain name, so I have a valid SSL setup, but the Mixed Content / Allow Insecure approach is common)

And Live on a dashboard…

For posterity’s sake, here’s some of the common Blue Iris UI3 URL parameters (and a link to the documentation with all of them):

  • tab - which tab is shown if the camera is minimized: live, clips, or timeline
  • maximize - set to 1 to maximize the video and hide the left and top control bars
  • cam - the shortname of the camera to show
  • group - the shortname of the camera group to show
  • streamingprofile - change the quality; must exactly case-sensitive match one of your streaming profiles (ex: 480p, 720p, 1080p)

Another trick to keep in mind is that you can prepend an @ symbol before a group and it will automatically cycle through all the cameras in that group. For example, you could use a URL like:

Thanks for the detailed reply.

Since I have NordVPN running 24/7 on the system that hosts BI, I have a Ngrok tunnel setup so that I can access UI3 when not on my LAN.

My BI settings are as you show them.

On my LAN I am able to access my BI UI3 via:


All three methods work via Chrome browser while on my LAN.

When I am not on my LAN both Ngrok methods work via Android Chrome.

I created the Custom Tile Editor as indicated, and it works fine when I am using the LAN-IP-Address:81/ui3.htm method.

However, both Ngrok methods do not work.

After logging in BI reflects it is “busy”

Since I am a new user and it won’t let me upload more than one picture, I have combined them all into this:

The http link creates 1 error each time I attempt to preview it. This error is to the right of the “busy” server in the picture above.

The https link gives me creates three errors each time I attempt to preview it. These are the three errors at the bottom in the picture above.

I am hoping you can enlighten me as to why the Ngrok methods do not work when the same links load without a problem via Chrome, as well as suggest possible solutions.

Thank you again for your time and attention. Have a great one.

That’s probably a better question for the Blue Iris developer. I would send an email to them using the Get Support button within the Blue Iris app.

As for how you describe the issue, I would not describe it in the context of SharpTools as it is not unique to SharpTools. Instead, it seems to be an issue with iframes and how cookies are set by Blue Iris. In fact, you can reproduce the issue by embedding Blue Iris within an iframe on any site.

Note that you could uncheck the ‘Use secure session keys and login page’ under the Blue Iris Settings → Web Server → Advanced, but this completely disables the login screen and instead would use the browser’s native credentials prompt which isn’t as pretty, but bypasses the cookies issue.