Help with Fully Kiosk Controller Device in SmartThings

To be able to trigger a new screen would be a game changer for my setup, but I cannot make it work

  • I have in st ide installed the dth and added a device and it seems to have been done correctly as I can see the device in the st app and in webcore
  • I have enabled both kiosk mode and remote administration in fkb
  • I have added the fkb server ip address in the device settings in st (added without ‘http://’) as well as the port (‘2323’)
  • I have added the remote admin password from fkb in the st app as server password
  • Have left all other settings in the st app empty

However, when triggering the fkb device in webcore and asking it to load a specific url (including 'http://) nothing happens

Anyone having an idea about what I am doing wrong?

If I remember correctly, isn’t there an option to test the Fully Kiosk device in the SmartThings mobile app? Like the ability to play a sound or something like that?

Tagging @James as I think he still has this setup in his SmartThings account.

@Claus_Hansen, see the post below for testing Fully Kiosk Browser’s remote admin setup. You can find the device in SmartThings app, tap the “Find sensor” button to test if the device and remote admin is configured correctly. (Make sure you have set an audio file URL in the settings first.)

I am not sure Fully Kiosk Controller Device is really working/supported anymore. I wrote a very similar but different driver about the same time with similar but different requirements. These both became very limited and difficult to maintain on the SmartThings platform and we both moved on to Hubitat. As a workaround you could write your own webhook directly in SharpTools to switch screens. The command was look something like this:

http://192.168.1.37:2323/?type=json&password=623456&cmd=loadURL&url=https://sharptools.io/dashboard/view/voELLOOXX2UrqgaaRg?kiosk=true

where you need to replace:
192.168.1.37 with your FKB IPv4 address
623456 with your FKB password
https://sharptools.io/dashboard/view/voELLOOXX2UrqgaaRg?kiosk=true with your URL

You should be able to get that command working in you browser before attempting in SharpTools webhooks.

If you want to jump to Hubitat…different discussion…

thanks, that worked in the browser, but cant figure out where to use it as an action in sharptools

After posting…sorry there isn’t a way. You will need a local webhook DTH to make this work. Give me a second, shouldn’t be too difficult to put one together for the current SmartThings IDE. Once that IDE goes away, this would be dead code.

Install this DTH in the SmartThings IDE. I would use the IDE editor to enter the default values. You will need to separate the IP, Port and command line. Ensure you assign it to a hub when you create it.

It should look something like this when done:

you don’t need the json part so the cmd looks this this now:

?password=333333&cmd=loadURL&url=https://sharptools.io/dashboard/view/voESTFFEEUrqgwcRg?kiosk=true

Driver works with both Hubitat and SmartThings. I didn’t do a lot of testing, so let me know if you get hung up.

Here is what should look like on the iPhone mobile app:

thanks a lot for all the help

tried this and made a rule in sharptools turning on a virtual momentary webhooks switch, but nothing happens

also, when trying to open the new switch in the smartthings app i get ‘cant connect to device. check device and try again.’

Can you send a screen shot of the IDE like above? Also, check you have it assigned to a hub.

thanks, forgot to assign to the hub, now it works!

is it correctly understood that you would have to have one device for each dashboard you would like to be able to jump to?

Do you recall if you assigned the device that was created with original Fully Kiosk Controller DTH to a hub? Pretty sure @James tested that DTH and verified it was working just last month based on the post he linked to.

With the Virtual HTTP Switch / Momentary that @Bloodtick_Jones put together, it looks like you would create a device per command you wanted to send (at least the way the DTH is structured today).

With the Fully Kiosk Controller integration, it’s more like a virtual device for the tablet. So you could have a single device and then use SharpTools Rules to send different commands… even using parameters in each tile configuration to choose what command to send in the rule.

just checked, and did assign to the hub, but cannot make it work

If you share some more details, maybe we some screenshots, we might be able to help.

Have you checked the SmartThings IDE Live Logs while testing the device?

The FKB drivers are a challenge to maintain with the changes from FKB and the depreciation of the original mobile app. The gavincampbell DTH (and mine) have completely depreciated the SmartThings support on the latest changes. I basically pulled out the command push in this virtual switch, but again it is only as good as the IDE remains.

I can put a public command if you want to use it more direct with automation such as webCoRE or SmartTools and repost. It is a very light uptool.

Made the the sendPostCmd command public with a string variable. You set it up the same as before, but can change the URL directly from automation as such:

Same github location.

Thanks for the new DTH, its great. I had a similar problem of not being able to get any of the existing DTH’s switching Dashboards.

Just combined it with the javascript:postMessage code, that Josh published last year, for fast switching between Dashboards, it opens up lots of ideas.

1 Like