Google Maps route no longer showing

I have a dashbord with a custom tile that show my route for work in Google Maps. That has worked like a charm for a long time and it still does in a browser or on my Iphone. However, it is not showing on an old Ipad of mine running iOS 12.5.7. I use the Kiosk Pro Lite app on the Ipad.

Does anyone have any idea what has changed since it is not working anymore ?


Do you mean that the Custom Tile still works in a normal Safari browser on the old iPad running iOS 12.5.7? It just doesn’t work within the Kiosk Pro Lite app anymore?

Edit: I noticed you’re in the beta group. Are you accessing the beta site or the main site on the old iPad?

Hi Josh

Your question send me in the right direction. It works fine on the Main site :slight_smile:

1 Like

Hi again Josh

I’m sorry I thought the Beta version was the issue, but that was not it it :slightly_frowning_face:

On my Old IPad the Google Maps route does not show in a browser or in the kiosk app.


Do other Custom Tiles work and it’s just this Google Map one that doesn’t work? For example, if you create a new HTML Custom Tile and leave the default content, are you able to preview that tile?

I just tested on Safari on iOS 12.4 and I’m able to view the default custom tile without issue:

If the default HTML custom tile doesn’t work, can you please try to:

  1. Manually refresh the page in your browser while viewing SharpTools to make sure you have the latest updates, then try again
  2. If the manual refresh doesn’t work, clear the cache for your browser, then try again.
    • Safari: iOS Settings > Safari > Clear History and Website Data).
    • Kiosk Pro: Refer to their documentation

Hi Josh
The HTML Custom Tile does work, but it seems that all Custom Tiles with URL does not work :frowning:

Again, thanks for helping.


TLDR :yawning_face:: It looks like the Google Maps embed only works on iOS 13.4 and newer.

Have you tested URLs other than from Google services? If so, can you please share those?

It’s certainly not all custom tiles with a URL that don’t work. I’ve tried several URLs and they work on iOS 12.4. I would note that Google blocks embedding their normal pages in other sites by default.

Some of their services, like Google Maps, have special ‘Embed’ versions of their pages. I just tried a Google Map embed and it works on newer iOS versions but not on iOS 12.4 – that’s not unique to SharpTools though. I suspect something changed on Google’s end that broke compatibility with older iOS versions (more on that below).

For example, I put together a simple demo page that includes the ‘Embed’ from Google maps as well as an image from a search for ‘Traffic in {city name}’. And that simple demo also fails to load the Google Map embed on iOS 12.4, but it works on newer iOS versions.

From a bit of testing various iOS versions, it looks like the Google Maps embed only works on iOS 13.4 and newer now.

Hi josh
Yes, it is probably a recent change on Google’s site that has broke compatability as you mention :-(. I have tried following url’s that also do not work.

Windy: Wind map & weather forecast" frameborder=“0”>

Can you clarify what you mean?

I just tried these on a modern device (Pixel 7) as well as iOS 12.4 and iOS 11.3 and they worked in all cases.

Hi josh

I just agreed with you statement 'I suspect something changed on Google’s end that broke compatibility with older iOS versions’, and then shared some url’s that also do not work on my old Ipad as you requested.

Let me know if something else is unclear.

Those URLs all worked for me. Do those custom tile URLs work on other devices in a regular browser or when viewed in Safari on the old iPad?

If so, you might reach out to the Kiosk Pro Lite team to see if they have any suggestions. It sounds like they have some sort of Allowed Domains and Restricted Domains setting for Embedded Content, but the documentation indicates that it’s only available in their Basic, Plus, and Enterprise versions.