Fully Kiosk, kiosk mode does not stick

I am using fully kiosk, and I put the ?kiosk=true which works 100% when select the option to go to home screen. But, after the tablet sleeps, then wakes on motion, it is no longer in kiosk mode.

@Armand_Welsh, can you provide a bit more information about your Fully Kiosk Browser’s settings? Did you include the ?kiosk=true parameter in the Start URL? and does this happens no matter if you’ve navigated to other dashboard/pages before it sleeps?
This is definitely not expected behavior so I’d imagine some settings in FKB might have caused this.

Happy to. As stated in my post, ?kiosk=true is there, and that works 100% of the time, when I navigate to the start page (page swiping from left to expose fully’s menu, and select Go Start Page.

How would you like me to send my configuration?

I think James was just asking what settings have been changed in Fully Kiosk Browser - or for that matter, any automations or rules that might be interacting with Fully Kiosk Browser.

So, I have isolated the specific scenario. if I swipe down to force a refresh (and I do have fully kiosk force a refresh on certain conditions), then the refreshed page load with kiosk mode turned off.

so, to reproduce, go to start page, then navigate to another dashboard, force a fresh, and post-refresh, the dashboard is no longer in kiosk mode.

I just turned the address bar on, and apparently the query parameters are removed when navigating to another dashboard. The kiosk mode remains enabled, until you refresh the page, which renders w/o the query parameters, since it was removed from address. I am guessing you are likely using a router to push the address onto the address bar, rather than actually navigating to the new URL, since this appears to be a Single Page Application. So the fix should be simple… when pushing new addresses into the browser’s history for the router feature, just append any query parameters to the pushed url.

When you manually add the ?kiosk=true parameter to the URL, it tells the SharpTools.io web app to enter kiosk mode. It stays in that mode as you navigate around unless it’s explicitly told to exit or when hitting a non-dashboard page. For example, if you use the Dashboard Tiles or hyperlink to another dashboard, it stays in kiosk mode. As a counter example, if you hyperlink to the list of dashboards, you’ll automatically be exited from kiosk mode. Similarly, if you manually hyperlink to another dashboard with ?exitKiosk=true, it will exit kiosk mode.

When you use the Dashboard tiles, you are routed to the other dashboard’s URL, but it does not attempt to retain any manually added query parameters.

So once you’re on another URL which does not have the ?kiosk=true, if you refresh the page, it’s equivalent to reloading the web app and since the kiosk mode startup flag doesn’t exist on the page, then you don’t get entered into kiosk mode.

Can you help me better understand these scenarios? Why is the page being manually refreshed or being refreshed through an automation? Why not reload the start URL instead?

I would think that this behavior is counter-intuitive. When I enter kiosk mode, and I use the “Dashboard” tiles to navigate between dashboards, and I then issue a “refresh” of the page, I would expect the refresh to re-render the page as-displayed prior to the refresh – but with new data.

The reason for this is when network issues occur, the links break, and web-sockets are severed. I don’t want to have to reset back to the start page, I just want the page I currently have visible to render correctly, so the page is re-drawn with functional tiles.

I don’t know if you are using web-sockets, or polling the server to updates, but when the wifi drops out, this breaks, and tablets are not the most reliable devices for staying connected to wifi. Now that I know it is the refresh, I can go back to the “Web Auto Reload” options and turn off all the auto-reload options that are turned on. But still, if I cannot use pull-to-refresh, since this exits kiosk mode, I will need to disable that feature too.

This seems less than ideal, but I will make those changes to my settings for now, and try to explain to my wife how to bring up the start page when things stop working.