First Alert Smoke/CO detector

Hm. The screenshot of ‘Current States’ from your hub doesn’t look right. It’s showing the value under an attribute called CarbonMonoxideDetector (which is the correct name of the capability), but the attribute is supposed to be named carbonMonoxide.

Is this a community developed driver or an official Hubitat one? Either way, I’m sure the driver developer would like to be aware of the issue so they can correct it.

This is not a offical by Hubitat.

I read some information here

Use this Driver to Smoke from PrayerfulDrop, works well.

For Monoxide Detector
I use this information below from Ryan780 to modified the Driver

Please see below new print from my Hub:



But on my Dashboard did not work.

Thanks for the additional details. Since you’ve updated to a new driver there are two things you might need to do:

  1. Complete the authorization process again
    This causes SharpTools to resync your devices over. If any of the underlying capabilities or attributes change when you change drivers, this gets them in sync.
  2. Refresh the dashboard
    Since the proper attribute wasn’t available originally, the dashboard probably wasn’t able to setup the requested subscription. When you refresh a dashboard, it will kickoff a healthcheck that looks for missing subscriptions and corrects them.

No lucky yet, please see the log from Hubitat

That looks like the logs directly from the custom device driver. What about the steps above?

  1. Complete the reauthorization making sure your CO2 device is selected and synced over.
  2. After completing the authorization, wait several minutes to make sure the device synchronization is complete and double check the device details in SharpTools.
    • If you are adding new devices, you can watch the location details screen and the devices will sync over in real time. From your user page, tap the ... next to your location and you’ll see a list of things for that location. Once the device is synced over, you can click on the device name to view the details of it and make sure it is reporting the correct attribute name and value.
  3. After the synchronization is complete, manually refresh your dashboard page to kick off the healthchecks.

Josh I did all of your steps.

I am think something wrong on my Driver, I never modifier a Driver, I will ask for some help on Hubitat Community to check the Driver.

Thank you!

Hi Josh,

I have new Driver, work well on Hubitat DashBoard, please see below.

But did not work here, the value never changed, aalways show “detected”

Thanks for the screenshots. That attribute doesn’t appear to be subscribed at the moment as indicated by it being grayed out. Add it to a dashboard in a Hero Attribute Tile or a Trigger in a SharpTools rule and it will automatically get subscribed when the dashboard/rule is saved.

1 Like

Congratulation work well now! :grin:

image image

You are really helpful.


SmartThings: I was able to add the smoke detectors in STs Classic / SharpTools under Additional Devices (which sensors section) but they don’t show up when I try to authorize them on SharpTools web. When I go back to SharpTools in the STs Classic app I see the smoke detectors have disappeared.

Welcome to the community and thanks for posting.

After authorizing the devices via the web, you can go back and add the extra devices via the SmartThings app and it will sync them over automatically.

It has to be in that order though - the web authorization only lists the core capabilities and will drop the ‘extra’ selections, so you want to do web first then modify it via the mobile app.

1 Like

Thank for getting back to me so quickly. It worked! Many thanks!!


I have some of these hooked up via Ring Security into Hubitat, and I don’t see them available to bring into Sharptools. I don’t even see a section for Smoke detectors in the Sharptools import tool. What am I missing?

You may be able to authorize them manually as noted here:

That did it, thanks!

I’ve manually added my 5 First Alert ZCOMBO devices and have added them to my dashboard, but they only have two layouts: Battery Tile & Hero Attribute

How can I get status?

Use the Hero Attribute layout and edit it to use the attribute you want.

That worked perfectly! Thanks

Sorry for jumping in. I have the same problem although connected to SmartThings.

Hi @GobenaShiferaw_Shife, welcome to the community. Are you having issue adding the First Alert smoke detector from SmartThings to SharpTools? You can manually add them by following the steps in this post below.