First Alert Smoke/CO detector


#1

I just purchased a couple of First Alert Smoke & CO detectors (Z-wave). When I tried to put them in Sharp Tools, the only attribute shown is battery. I need carbonMonoxide and smoke attributes, as well as acceptable icons. Any chance they can be addded?
https://www.firstalert.com/product/wireless-smoke-and-carbon-monoxide-alarm-with-iris/


#2

This is connected to Hubitat, right?


#3

Yes.

Admin Edit: removed personal info


#4

Nice request, I upgraded all my smoke/co detectors to this model, I did not test them with Sharptools yet, but I received the email with the summary and this thread was there.


#5

@Dan_Fox I just tested by creating a Generic Z-wave Smoke/CO Detector in Hubitat and it looks like the SharpTools HE app is subscribing to the smoke and carbonMonoxide attributes, so I just need to make a tweak to the UI to expose these attributes. I’ll see if I can squeeze it in the next release - thanks for the suggestion!


#6

:+1:
That is the driver this device uses. Thanks


#7

Tonight’s SharpTools.io platform update includes support for smoke and carbonMonoxide attributes on Hero Attribute tiles for Hubitat devices. Thanks for the suggestion and your continued support! :smiley:

(To use the updated feature, be sure to refresh your dashboard pages)


#8

Great. Thanks for the update!


#9

I have a first alert (smoke only model: ZSMOKE) device I purchased several years ago. It’s running on Hubitat fine but is not showing in the list of available devices on SharpTools. All my other devices are fine.
I’m sure I’m missing something obvious!
Thanks!


#10

Try using the instructions in this post to authorize it as a Sensor/Actuator from the built in Hubitat admin UI:


#11

Thank you! Knew I was missing something.


#12

I just was looking through the forum and saw this post. Is there a way to show on tiles through Smartthings? I don’t see an option to add, but I may have missed it somewhere.


#13

Hi Brad,
You can add First Alert Smoke detector to SharpTools through SmartThings app (classic). Go to “Automation”-> SmartApps -> Select SharpTools -> tap on “next” at right top to add additional Devices -> “Which Sensors” -> then check the box next to the smoke detector and Done.


#14

@James has you pointed in the right direction with how to authorize additional devices in SmartThings that don’t have a core supported capability. In this case, we still need to add Hero Attribute tile support for carbonMonoxide and smoke for SmartThings - I’ll take a look at prioritizing this for an upcoming release. :slight_smile:


#15

That would be awesome. Thanks @James and @josh!


#16

@Brad_Yuly just an update that a recent SharpTools.io platform update added support for Custom Attributes in Hero Attribute tiles, so smoke and carbonMonoxide attributes should be available to you now. :grinning::+1:


#17

I have the same detectors, and they are setup and working in Hubitat, but when I import all of my devices to Sharptools, they are the only ones that do not show up in the list. What am I missing.

I do not even see it as a category in the list like it shows other categories even though noting is listed.


#18

@Albert_Mulder Since it doesn’t have the core supported capability, it is not showing as a category in the list. However, you can still add it via the “additional device page”. In Hubitat page, go to Apps -> select SharpTools -> click on “Next” at the bottom directly -> click on “Which sensors” in the Additional Devices page -> check the smoke detector and Done.

And don’t forget to change the tile layout to “Hero Attribute”, so you can select smoke and carbonMonoxide attributes to be displayed in the tile. :slight_smile:


#19

How long does it take for them to show up in SharpTools? I have them selected in Hubitat as you described, but they do not show for me to add them in a rule or dashboard as a thing. Even Loged out and back in. still nothing.


#20

It should show up pretty quickly. If you haven’t seen it available in the list after a couple minutes, there might be something went wrong. Try remove and re-add it using the approach I mentioned, and send us a ticket (https://help.sharptools.io) if it still doesn’t show up, so we can help look into it. Thanks.