Fire + TinyCam + Fully + Mixed Content

Okay, so the below URL properly opens in a Chrome browser and displays the feed along with the “:warning: Not secure” message. Surprised as I didn’t think I would actually see the picture for whatever reason.

Even after I clicked “Allow insecure content”, I still have the warning message.

However, when I then insert the into the URL, I get the usual NXDomain error implying the domain doesn’t exist.

This site can’t be reached

Check if there is a typo in

  • If spelling is correct, [try running Windows Network Diagnostics](javascript:diagnoseErrors()).


We would really need the details to be able to help. Otherwise we’re guessing at lots of details that could impact things (like what the full URL you used for testing was).

Also, is there anything special about your network configuration? Especially things around DNS resolution? I would also make sure you can visit directly in your browser without issue. And you could try using the dash format instead:

Or one of the other providers mentioned above:

Again, the details would really help here. Especially a screenshot.

You shouldn’t have been prompted to Allow Insecure Content in Chrome if you were visiting the camera URL directly. If you did, that could be indicative of something wrong. Since you played around with the SSL settings, make sure you completely restarted TinyCam to make sure they took effect once those settings were reverted. Or try restarting your phone too.

If you are prompted in any way (in a fresh incognito tab), that’s likely going to cause an issue. For example, you shouldn’t see a login prompt and you shouldn’t have to explicitly accept insecure content.

Sorry, not sure what details I’m omitting. But…

Using TinyCam Pro with webserver enabled on a NVidia Shield, port set to 8083, is the address of the Shield.

Have resources set up in my dashboard with the URLs to various cameras (have 7 cameras on the TinyCam). For instance, is my front door camera.

The tiles work on my Amazon FireHD8 2017 tablet, but do not work on my Amazon FireHD8 2020 tablet.

I’m testing this on a laptop using Chrome.

Clicking on works fine on the desktop.

I tried all links above, get the same NXDomain error.

Nothing special that I can think of around my network/DNS setup.


No prompts for passwords etc, goes right to the image.

Something is wrong with DNS somewhere along the line if you are getting the DNS_PROBE_FINISHED_NXDOMAIN error in Chrome with all of the above examples.

The screenshot doesn’t look like an incognito window. If you were ever prompted for your credentials or accepted any prompts, the browser could be saving those. That’s why it’s important to try a fresh incognito session.

Incognito, no popups either.

Let me try from a non-work laptop to see if works.

Bingo… URL embedded link works fine from my home laptop. So probably a DNS or restriction somewhere my company puts on the laptops. Now to see if it works with Fully.

@Jordan_Welker, by chance did you figure out how to get Fully to work again? I seem to be having the same issue that you are where even adding in into the address doesn’t work.

I suspect that Jordan’s issue was slightly different as they mentioned that didn’t work at all for them and they had mentioned that in the context of Chrome. Without more details, it’s unclear what their configuration was though.

Fire HD 8 Test

I just tested on a Fire HD 8 Plus (10th gen) with the version details shown in my screenshot below and it worked for me.

  • It was showing Fire OS installed from February or earlier. After that, I went through a ton of updates manually.
  • Unfortunately, I forgot to check the Webview version with my original test, but you can see the version details in my screenshot below.
  • You can access the ‘Device Info’ from my first screenshot within Fully Kiosk Settings → Other Settings (bottom) → Device Info (bottom)

Have you gone through these steps, noting the results of each, to help narrow things down?

Desktop / Laptop on Chrome (if available)

  1. Test the camera URL directly in your browser:

  2. Test the URL directly in your browser:

  3. Test the URL within a SharpTools Media Resource
    (SharpTools User Page > Manage Resources > Media)

Fire Tablet (Silk Browser)

  1. Test the camera URL directly in your Silk browser:

  2. Test the URL directly in your Silk browser:

  3. Test the URL within a SharpTools Media Resource
    (SharpTools User Page > Manage Resources > Media)

Fire Tablet (Fully Kiosk Browser)

  1. Test the camera URL directly in your Fully Kiosk browser:

  2. Test the URL directly in your Fully Kiosk browser:

  3. Test the URL within a SharpTools Media Resource
    (SharpTools User Page > Manage Resources > Media)

Sorry just getting back to this.

Just tried it on my 2017 Fire HD8 tablet.

The link opens up fine in the Silk browser.

It won’t open in the Fully browser…

The standard camera URL works fine in the Fully browser.

Have to try it on a non work laptop as well.

Also, the link works fine on my iPhone in Safari, not in Chrome.

Tried it on a non-work laptop. Same issue, Chrome and Firefox give the “We can’t connect to the server at” error.

So it works on Safari and Silk, but not Fully, Chrome or Firefox. Could have sworn it worked on another one of my personal laptops but can’t recall which it was.

Unfortunately, I’m unable to help without the details.

It’s really important to include the results of each step along with the details of any error messages (screenshots preferred). And in general, it’s important to include details like version numbers, device make/model, and any other relevant details about the configuration or testing.

As a free user, we try to offer as much support as we can through our community and documentation. Providing these details will enable both us and the community to assist you more effectively.

I’ve tested each of these steps on a variety of new and old devices and I’m not able to reproduce the issue. The DNS_PROBE_FINISHED_NXDOMAIN issue mentioned above is clearly a DNS / networking issue. It’s not clear exactly what error messages you were seeing when things weren’t working with some of your recent tests but “We can’t connect to the server at XXX” sounds like a networking error.

That’s part of the reason I asked for result of each of the steps above: it starts with a fundamental validation of network connectivity to your camera, then tests which should only be a difference in DNS resolution, then tests it as an embedded resource which is where most browsers get the most finicky.

Okay. First series of pictures is all on Silk Browser.

Top right on dashboard is driveway stream. Rest are all not on In Silks case using the sharp tools dashboard it does not show either or direct URLs.

Next is Fully. Again, Top right on dashboard is driveway stream. Rest are all not on

Versions of Tablet and OS.

Chrome laptop:

That looks like a DNS issue. What happens with the traefik and versions?

Just curious, but if Silk works for but Fully won’t on the same tablet, doesn’t that rule out a DNS issue?

Unless each browser allows you to change DNS settings which I don’t believe is the case?

@josh Just getting back to this. Did I provide everything you needed above? I don’t think it’s a DNS issue since some browsers in the same device work while others don’t, which unless there are specific DNS resolution options within each browser (and I don’t think there is), implies it’s not DNS?

I didn’t see which WebView version is being used. :point_down:

The error message ERR_NAME_NOT_RESOLVED reads as a DNS resolution issue. That doesn’t necessarily mean it’s an issue with your internet, but it points to a DNS resolution issue in that screenshot.

Understanding what WebView version you are on and ideally updating it to as new of a version as you can would be ideal here.

I would also be curious about these results.

Hey @S_D - did you see my responses above?

  • Please share the WebView version (steps above)
  • The error is a DNS resolution issue; could be something special in the webview though.
  • What were the results of testing the traefik or versions?

I also put together a proof of concept with our own DNS resolver that effectively does the same thing as these services if you wanted to try it. It’s available at {local-ip} formatted like the others.


Finally got back to this. Screen shot of WebView is below. Tried the and receive the same error that the image can not load (using Fully).

How do I upgrade the Webview?

Okay, so updated Fully to 1.53 and used an apk to update the webview, now things are actually worse as Fully doesn’t show any streams (before it would show the regular IP addresses but not the ones with or

Is there anything in my Asus router settings I should check as it relates to not resolving or similar?

Right now both my tablets are useless (as I also need to figure out how to get my Harmony integrations working again…saw some threads on that but tackling this first).

Lastly, I’m using Tinycam as the webserver as it was less intensive than using BlueIris. If there is an easier way to do this using BlueIris, I can try that as well?