Fan not responding to "on" command

Hi, I installed a wifi fan controller ( and connect to home assistant. Works perfectly in home assistant, but when I make a tile for it in SharpTools and set it to either Cycle Speeds or Show Speed Picker, it will only respond to speeds and off, but once it’s off, it will not come back on. I can actually watch it changing speeds in the Tuya app, but the fan speed stays off. Again, it works fine from Home Assistant.

Can you send a diagnostic export from the SharpTools Home Assistant add-on to along with the entity ID of the impacted device?

Hi Josh, I was able to get around the issue by creating a rule that said if the speed changes to anything but off, turn the fan on and that works. However, I’ll send it over in case you want to take a look and make it work inherently.

Thanks for the additional details. If the fan is off and you use the Home Assistant developer tools > Services to send a set_percentage service call to the fan, does the fan stay off?

No, it doesn’t turn on. The tile comes on in sharptools, but the fan doesn’t turn on and doesn’t show on in HA or Tuya.

I have another fan that won’t turn off using a sharptools tile. It’s a Tuya integration via Home Assistant. I’ve used the cycle speeds and when it gets to off, it just skips Off and goes right to Low. I’ve also tried changing Layout to Switch and it will turn Off, but when I try to turn it on, it says Error Sending Command and doesn’t turn on. Any idea how I might be able to get this working correctly? All works fine in Tyua app and in Home Assistant.

Was it included in the diagnostic report you sent earlier? If so, feel free to reply to that email with the entity id.

Note that with Home Assistant finally deprecating the legacy set_speed() / speed_list functionality in recent releases, the fan tile in SharpTools should fully rely on the set_percentage() service that all devices in the fan domain should support.

The off speed in a fan tile effectively maps to sending a set_percentage(0). Based on the other comment above, it sounds like the integration you’re using in Home Assistant doesn’t implicitly turn the device on/off based on the percentage changing.

I solved the second problem by using a variable toggle on/off and calling it in the rule editor. I’ll keep what you’ve just responded with in mind. thanks

1 Like

@josh I’m finally back in the game at my new home! :slight_smile:

Having a similar issue with a fan using the Tuya integration. Have there been any further updates on this topic? I can provide diag if needed.

No. It sounds like an oddity of the Tuya fan integration with Home Assistant. Using the set_percentage() command with any value other than 0 normally will turn the fan on and 0 would turn it off, but this integration appears to be quirky. You can put together an automation which uses that same logic to turn the fan on/off when the percentage changes as a workaround.

Thanks @josh . I hate bastardizing things, but the HA automation workaround does get the job done.

1 Like