EVOHome Thermostat control

Hi all!
I’m giving SharTools a try (smartthings) and I find I cant control my EVOHome system very well. It works fine in ST, in the classic ST app and also in actiontiles.
When I add one of my EVOHome zones to SharpTools dashboard it displays well but the up/down arrows do not work, they are greyed out in fact.
I can make temperature adjustments by using the adjust link and making the changes in that window.

I have tried changing the thermostat mode but no difference.

Welcome to the community and thanks for posting! Sorry to hear that the thermostat isn’t working as expected.

Is this a community developed integration? If so, can you share a link to the device type handler?

For the single height thermostat layout, the adjustment controls are disabled when the thermostat is in Auto mode. You can change the thermostat layout to a Double Height thermostat which will show separate heating and cooling controls.

While editing your dashboard:

  1. Tap the ... in the top right corner of your single height thermostat tile and tap Change Layout
  2. Choose Double Height Thermostat
2 Likes

Thanks for the welcome - what a friendly place!

Yes, it’s a community DH:
https://community.smartthings.com/t/release-honeywell-evohome-integration/44953
https://github.com/codersaur/SmartThings/tree/master/smartapps/evohome-connect

unfortunately, the systems default mode is auto, sounds like this is the cause?

Can confirm with the double height layout the heat section does indeed work for me.
Is there some way to override this behavior, other than this (show stopper for me), I’m preferring to action tiles, you have a MUCH more natural UI and I like the rules gubbins.

1 Like

If I understand correctly, this is a heating-only device. Yes, the thermostat mode being hard coded to ‘Auto’ would prevent making adjustments in the single-height thermostat tile.

Officially, the “Thermostat” capability is deprecated in favor of individual thermostat related capabilities (eg. “Thermostat Heating Setpoint”) which works better for heating only devices like radiators, zoned valves, etc. It looks like this device handler was developed before that changeover though.

I went ahead and tweaked the device handler to use the new capabilities. Can you try updating your installation to use this copy, then reauthorize the device in SharpTools, and try again?

Normally if a thermostat is in ‘Auto’ mode, there’s not a clear way to determine if we should try to adjust the heating setpoint or cooling setpoint. But if a device reports that it’s only a heating device or only a cooling device, then we know which setpoint to adjust and can thus allow adjustments even in Auto mode.

3 Likes

Thanks for this, I have made the chages in the DH and thought for a while it hadn’t worked but something must have taken a few minutes to update.
Seems to be working now though.
I will test all my other automation (webcore etc.) now.

Great support, thank you so much!

Spoke a bit too soon :frowning:
Adjustments to setpoint work as expected but when a zone starts heating, the state does not update on all zones, most always displays Auto(idle) despite it changing to Auto(heating) in SmartThings. I can confirm this state is still changing after your suggested mod as it is still displaying in ActionTiles properly.

One zone does update state successfully, it is alphabetically the first zone…

I’ll send you a PM to gather a few details for troubleshooting.

Edit: Just an update that Ian indicated via PM that things started working as expected. :smiley:

Hi Josh,

Can I join in on this too? I have this same issue too with the same ST device handler as @ian and would love to see the thermostat buttons working.

I’m about to update the device handler to your edited version.

Thanks

Thanks for posting, @mark_oswell! Let me know how it goes when you change over to the new device handler.

If everything works well for you too, I’ll submit the update to the device handler’s author for their consideration. :slight_smile:

Just remember that you’ll need to reauthorize the device in SharpTools after updating the device handler… that way SharpTools becomes aware of the new reported capabilities.

Came across this thread while researching the same issue of the single height thermostat tile not working with Evohome. Have updated the device handler with the modified code provided by @josh and now it’s all working fine. Thanks as ever for the superb support!

2 Likes