Ecobee Temperature Way Off

I have two ecobees I control with my dashboard, however the large temperature reading never changes. Also, the tile only updates the color if I manually push the up or down arrows. I have looked around in the dashboard and tile settings, but can’t seem to fix this. As you can see by the picture, it knows what temperature it is currently in the corner. Any ideas?

@Aaron_Tuomala, welcome to the community. The temperature reading shown in the center of the single-height thermostat is the ‘Thermostat Setpoint’ reported by SmartThings. Some thermostat devices in SmartThings do weird things like average the Heating Setpoint and Cooling Setpoint together which doesn’t make any sense to me either. :man_shrugging:

Since Ecobee supports both cooling setpoint and heating setpoint, I’d suggest you to use the Double Height Thermostat layout by tapping the “…” at top-right corner of the tile when editing the dashboard. So you can see the correct cooling and heating setpoint value correctly.
image

For thermostat tile color, you can customize the tile settings to enable heat/cool color so it will show red or blue when the AC is heating or cooling respectively. It resumes to the default color when the AC is idle. See below for my ecobee tile’s color in cooling/idle state. I set my thermostat mode to “auto”, and it changes to cooling or idle automatically based on my setCoolingPoint value. So the reason why it only changes color when you manually tap up/down, because that basically tells the thermostat to cool or idle.

image
image

1 Like

I will try that out. Not sure if it matters, but I am on Hubitat.

I really appreciate it!

Aaron

1 Like

I don’t know whether this is pertinent to what you’re experiencing, so feel free to disregard it!

Ecobee does average multiple sensors if they are set to “participate” in the same time period. For example, in my Home period, I have both the thermostat and a sensor in the family room set to “participate”. So the temperature displayed is the average of the two sensors, which may be different from the actual temperature at the thermostat.

Also, ecobee (mine is version 3) only reports its status every few minutes. For example, if I have changed the set point using the up/down arrows on the dashboard (or via Alexa) and later issue a Resume Schedule command, the thermostat will display the new set point right away, but the dashboard will not show it for several minutes.

I modified the data polling in Hubitat from 1 minute to 5 minutes and that seems to have helped. Also, I set my ecobees to Auto instead of Heat/Cool. Those two changes combined with the double-height thermostat setting seem to have done the trick.

2 Likes