Dashboard not updating with HE


#1

Hello Josh, @josh

I had an odd issue with Sharptools, for some reason it was telling me in the logs I was unauthorized, so I ended deleting the app from HE and re installing it, creating the dashboards again, a mess… But I have now another issue, the tiles are not updating the state, the power meter tile stays with the power measure when the tile was created, the water valve doesn’t update the status, or some of the light doesn’t update the status, no error logs on HE. I noticed when you manage HE from this website, the authorizing options are different than the ones in HE app, for example, in the web I can see water valve category but on HE app we have Actuators?

I need help! Thanks.


#2

Thanks for the message and sorry that things aren’t working as expected. :open_mouth:

What Hubitat firmware version are you running?


#3

Starting the authorization from SharpTools.io presents you with all the options that are available on the first page of the SharpTools Hubitat App configuration. These are all the standard device capabilities that we have dashboard tiles built for (eg. light switches, thermostats, color control, motion sensors, etc).

If you modify the SharpTools Hubitat App configuration from the Hubitat admin UI, there’s an additional configuration page with the generic capabilities ‘Actuators’ and ‘Sensors’. These are more like catch-all capabilities… there likely won’t be a tile defined for them, but you can still use them in Hero Attribute tiles and the Rule Engine.

PS. Note that the first authorization must be done from SharpTools.io as that’s what sets the API key that Hubitat then uses for communicating event updates to SharpTools.


Authorization from the web (left) matches authorization from the first page of the Hubitat app (right)

Then the second page of the SharpTools Hubitat App is the generic Sensor and Actuator capabilities…

image


#4

I’m in latest firmware 2.0.6.112. Yes, I did the authorization on Sharptools.io first, then I added other things in the HE app. But still not updating, and in my screenshot has a message on the bottom, what that means? Thanks

edit: example, this is a zwave switch, nothing special, it’s been on from the creation of the tile but the switch has been on and off multiple times, right now is off

maybe is not subscribed per the notification?


#5

I just deleted the app again, installed using Sharptools.io and chosen 2 devices, one switch and the water valve, not updating the status, I can control the device but they don’t change the status on the tile


#6

Thanks for the additional details. It sounds like the dynamic subscriptions aren’t working as expected.

If you enable debug logging in the SharpTools HE App and then try editing->saving the SharpTools dashboard which has the two devices on it, what do you see in the Hubitat logs?

You should see something like the following if the subscriptions are missing:

debug   Subscribing to `xx` : `attribute`
debug   BATCH addSubscription() HTTP request has been received and is being processed

#7

Nothing, I added a HSM disarm tile by the way and did not debug anything.


#8

The HSM and Mode tiles use a default subscription, so they won’t request a subscription. Because of that, those type of tiles should be updating as the HSM state / mode changes.

What about editing and saving the dashboard with the two authorized devices on it?


#9

I did too, but I got this now


#10

listSubscriptions() just means SharpTools is trying to check which subscriptions you have.

Just to make 100% sure, you have refreshed this browser in the past 2 weeks, right? We deployed some updates to the dashboards to dynamically request subscriptions about 2 weeks ago (before the Hubitat app update). So if you’re using a device which has had the dashboards open for a long time, it could be running the old dashboards.


#11

I always used chrome on android, but I discovered this using chrome in my w10 laptop. But not updating in fully too


#12

So have you refreshed the SharpTools.io dashboard with the two devices on your Windows 10 laptop? Maybe even tried in incognito?


#13

You mean the dashboard? Not setting it, correct?

I will try now incognito


#14

I just tried incognito, I had to login again to sharptools.io but still not updating the tiles.


#15

Thanks. Can you try opening your SharpTools.io dashboard (which has the two devices on it) in Chrome on your Windows 10 laptop, then press F12 and open the Console tab.

You should see something like the following:

Can you expand the “Location Subscription Healthchecks” and “Subscription Conditional check” groups and either screenshot or copy-paste the text in a PM to me?


#16

I will do it tomorrow, my wife just call me to sleep lol

Thanks for your help.


#17

Hello again, sending a screenshot in a PM now. Thanks.


#18

Thanks! Got it and replied! :smiley: