Dashboard Not Found In Fully Kiosk

I seem to have broken something, I daily use (setStringSetting) and (fast switching) in fully Kiosk, just lately I get Dashboard not found followed by a screen of blue tiles with white ? and then a spinning circle followed by the correct Dashboard

I can’t think of what I’ve changed to create the problem, any help


Can you share more details about what you are doing with the setStringSetting?

That sounds like a fresh load of the dashboard page (not a ‘fast switch’).

We released the realtime socket feature to production last week.

A few other people including @Wet.Blanket @JKB121 and @Terri mentioned they are seeing the “Dashboard not found” screen followed by the dashboard partially loading before being fully rendered as well.

All of you are part of the beta group though and I don’t recall seeing any reports of this during the beta, so I’m trying to identify what’s different here. One thing that sounds consistent in each of these scenarios is directly opening the dashboard for display rather than navigating to it through the UI.

I’m able to reproduce this using that approach so I’m going to take a closer look at improving this (it’s a very brief effect in my case, but clearly shouldn’t happen)…

No worries, I’m going to go for a fresh install as I have some other funky behaviour

The only thing I noticed in Beta was the “SOCKET CONNECTED” Message at the bottom. No real delay. I tried reproducing this yesterday on a Windows computer and could not. Could it be mobile related?

It does occur in Chrome on a Mac.

It could be that the computer is loading and then rendering much faster than the mobile device, so it’s not as noticeable.

Also keep in mind that the new realtime socket has some optimizations on desktop browsers. For modern desktop browsers, the realtime socket system uses a shared background connection across tabs. So if you already had another tab with SharpTools open, then the new tab would be a ‘hot’ load.

I sure do. Usually 3 tabs. 1beta, 1 regular, 1 rules.

I only notice it in my tablets. My mobile and PC are much more powerful.

I think I’ve only noticed this on FKB, not When using Edge. I haven’t been name to test it more though. And honestly I’m not too worried about it since it’s only a few seconds.

We’ve pushed an update which should resolve this. Please note that you will need to manually refresh the page at least once to ensure it pulls in the latest updates.

In other words, you may need to launch your shortcut and then pull-to-refresh the page or manually clear the cache in your browser depending on the type of browser.

Looks good to me Josh. Thanks!

1 Like

Solved mine too. Thanks Josh!

1 Like

It appears fixed for me as well

1 Like

I still have the dashboard not found issue on the Android devices, but now I’m seeing it on the Windows computers where I did not yesterday,

I have refreshed all devices, cleared cache, even restarted devices…

It sounds like the browsers are hanging onto an old version. If you can share more details about your browser, we might be able to provide further guidance on how to ensure the cache is cleared.

After you refresh the page, you should be able to navigate directly to manage your user profile within the SharpTools web app to see the version number. This must be done within the app navigation without opening a new tab / refreshing the page to have an accurate version number as shown in the video below.

Thanks for the feedback. We pushed out one more change on the backend which may resolve this.

Can you give it a try and if you are still having issues, perhaps you could record a video of the problem so I can make sure I fully understand what you are experiencing?

Working fine now. Thanks!

1 Like