Custom header size not working in Sonos control tile

Hi everyone, first time post. Let me say I am amazed at how great this tool is, and also by the incredible support I have seen in this forum! I’m excited to be a new SmartTools user. Now to my question/issue:

From reading this board I learned that if I want to have half-size tiles, what I really need to do is increase the column width and then make the tiles I want to be the same size 2x2, and the half size can be 1x2. No problem there, but as you know it makes the font size quite small. I searched and learned how to adjust the style of the tile to add a custom header and footer font size. It works perfectly everywhere EXCEPT the Sonos control tiles. For some reason it doesn’t seem to matter what size I choose for those tiles (even 600%), the font stays the same. In my screenshot below all the tiles have custom header size 250, but you can see the Label tiles on the left have a much bigger font.

I tried setting the footer size to 250 also, but it didn’t make a difference. Is this a bug, or am I missing something?? Thanks in advance!

@T_Shoaf, welcome to the community and glad to hear that you are enjoying SharpTools. It sounds like those Sonos tiles’ header font size is overridden somewhere.

Can you verify if you have set the .title font size in the theme’s Custom CSS field?

Or if those specific Sonos tiles are using the Custom Style in the tile’s configuration?

Thanks James! I am using the second approach, setting Custom Style.

Do you have any Custom CSS that overrides the header size? And do you set the Custom Style in Default Style or Active Style in the Sonos tiles? (You should set this header size in the Default Style so the custom header size will also be inherited when the tile is in active state.

Otherwise, I may need to the screenshots of these tiles’ style settings to get a better idea where things might have gone wrong.


Thanks James, that was it! I was setting the font size for the “Active Style” but not the “Default Style.” Once I set it for the Default Style the problem was solved. Glad it was something so simple! Thanks a lot for your help!