Changing device names

I set up a device in SmartThings and assigned it to SharpTools, however, when I changed the name in SmartThings, it does not change in SharpTools. I tried editing the device in SharpTools, but the name cannot be changed. Is there a way to do this?

Maybe try going to SharpTools Account / Manage Connections and re-authorize the devices again. You might have to re-add it that device dashboard with new name.

1 Like

That worked. I authorized another device and the update took for the old device.

1 Like

Usually this doesn’t need anything else than:

  • open Sharptools smartapp in ST app
  • click “next” and click “done”.


Well, it kinda worked. When I go to the rule, the device (a Fire tablet) still shows the old name, but when I edit it, it shows the new name. Unfortunately, when I save the edit, it still shows the old name.

I got around this by changing the device to another tablet, updating, changing it back to the original tablet and updating. Now, all is well.