Cannot change icon on temperature tiles bug

trying to change the icon on a temperature tile from the thermometer to “nothing”. works for some tiles but not for others. cannot find a common theme for why it doesnt work.

@Christian_Ytterstrom, can you take a screenshot of the tile’s icon settings so we can have a better idea how it is configured? Here is a quick example how to change the temperature tile’s icon to “nothing”.

I did exactly this for five aqara temp sensors. Three worked just fine and two kept their original icon despite choosing The same way. I reverted to using a custom theme having content being transparent. Still want me to screenshot?

Hi @Christian_Ytterstrom - thanks for the reply. Yes, it would be helpfult to have more details on how to reproduce the issue as I cannot reproduce it. The only time I’ve seen this happen is when the tile settings were saved, but the dashboard settings were not (or if the icon box was completely unchecked as the tile will revert to the default icon).

I would also note that if you are using the Temperature Measurement Tile layout, you have the option of making the temperature value the main content instead of an icon. :slight_smile:


I want to use The icon setup because i want The name of The room as header and The temp as footer not icon, as a headline for The room :blush:

See images, taken in steps

2 changed but not saved
3 saved tile, save dashboard, Edit, Edit tile.

Thanks for the screenshots.

Edit: my colleague indicated that he reproduced the issue once but is still trying to figure out how to consistently reproduce it. We will take a closer look and see if we can figure out what’s going on. Thanks for reporting.

If I add it to a new dash it works. The difference between The ones Who worked and The ones Who didnt is that i had tried earlier to replace The icon. Ill try to remove them and redo The process. Perhaps something got bugged first time.