Cameras and saved passwords

Got a couple issues here with chrome and Cameras over LAN.

For PC if I follow the directions and enable insecure content I can see the cam image. When I exit chrome and go back in it doesnt work unless I pull up the cam image URL in browser and redo the name/password. Then open dashboard and its OK. I have the passwords saved in chrome. So why doesnt it stay?

For Samsung Tablet I followed the instructions and have to do the same to get it to work. So after using the cam image URL and putting in name/password it works if I go into sharptools. However its does not work with Wall Panel APP which just uses the same sharptools URL. Wall Panel app got other security?

These are Hikvision stand alone cams. Media link looks like this:

Hey @kampto thanks for posting. I’ve moved the post out into it’s own topic as it doesn’t sound like the remaining issue is directly related to Chrome Mixed Content limitations.

From what I can tell, it sounds like the issue is related to credentials for media resources. Opening the camera page directly and manually logging in will temporarily store the credentials and jump start the streams for the embedded resources as you noted. But to avoid having to do that every time, the credentials will need to be embedded in the media resource URL. The approach for this varies from camera to camera.

The ‘workarounds’ section of the following article has guidelines that are relevant here as well:

You may want to try to append the auth parameter in the URL like mentioned in this post. However, we have seen other posts mentioning this auth method is disabled after a newer firmware update on the Hikvision cameras.

I’ve tried the following to get the image to open in a chrome URL. If I can get it to open in Chrome then ALLOW “insecure content”, it will show in sharptools on PC. However even though the credentials are in those camera links, chrome still asks for a password if chrome has been shut down and restarted, and if I don’t do that it wont show in sharptools… And yes I have the passwords also saved in Chrome settings.

Hikvision Cams:
WORKS: http://admin:password@

I cleared all my chrome cache and history. Still askes for password after its been saved. A google search finds this is common problem, haven’t found the secret yet…

This has been an ongoing problem. I cant get camera image to open in SharpTools at all anymore. And I have allowed insecure content. It worked for about a week.
It still works fine in the chrome browser using this link.
So it works in chrome but not SharpTools with chrome.

Thanks for sharing an update. It sounds like the ‘auth’ parameter isn’t working as expected. As James mentioned, it seems like Hikvision has deprecated this parameter in later firmware versions.

And based on your previous description of Chrome prompting for a password if Chrome as been shutdown and restarted, it sounds like you’re still being prompted for credentials which are then cached temporarily.

Have you tried reaching out to Hikvision to see if there’s an updated way of passing the authentication credentials (eg. different parameters)?

Is this something Sharptools can add for media as an option for mixed content?
Not sure if it would work or how to test it.
<meta http-equiv="Content-Security-Policy" content="upgrade-insecure-requests"> tag in your HTML’s <head>

The latest versions of Chrome already do something similar to this. If anything, it causes issues rather than helps in this scenario. See Google Chrome - Mixed Content - Media Not Showing for more details (the ‘Other Details’ section covers the auto upgrade to SSL).

All indications are that the issue you are experiencing is with getting the authentication credentials passed over to your camera.