Bose SoundTouch 10 Sharptools interface down?

Hi, I have several rules that have worked reliably in Sharptools for many months that trigger and play sound files on my Bose SoundTouch 10 speaker. Yesterday 5/17/2023 they stopped working. I logged into SharpTools and verified that the rules were firing, however when I brought up the Dashboard with the SoundTouch device, and I try and manually send commands such as start, stop, play, etc. I get a red error notice saying “error sending command”. I am able to control the device from SmartThings so I know there is communication, but I can’t seem to do it from SharpTools. Can someone confirm that this Sharptools to SmartThings Bose Soundtouch interface is down? Maybe I am missing something, but it doesn’t seem to be a rule issue. Thanks for any comments you might offer.

Thanks for posting and sorry to hear that things aren’t working as expected.

Am I understanding correctly that your SharpTools rules that control the Bose Soundtouch device are working, but you aren’t able to control the device from your dashboard?

To clarify, SmartThings handles the communication with your Bose Soundtouch devices. From the SharpTools side of things, all the devices are exposed from SmartThings with their various ‘capabilities’ and the system presents the appropriate tiles in the dashboard based on that (and commands in the Rule Engine based on that). There’s not a special ‘interface’ for Bose Soundtouch - just that SmartThings exposes that device as a media player so SharpTools knows how to interact with it.

Can you send a note to support with the following:

  • Rule ID that is working and is able to control the Bose Soundtouch
  • Dashboard ID where you are unable to control the device
  • Doc ID of the device in question (how to)

I think SmartThings may have released their Edge driver for Bose to production yesterday. Perhaps your SmartThings devices have converted over to drivers and this issue is related somehow. Maybe try refreshing your SmartThings/SharpTools connection?

1 Like

You sent and asked for the information to be sent to support but it may contain urls and IDs that shouldn’t be published. How do I reply to support?

Send a note to

This very likely could be the issue. As @Nezmo mentioned, you can reauthorize your SmartThings connection which will do a fresh sync of the devices and pull in the updated details for the device.

  1. Navigate to your SharpTools User Page
  2. Tap Manage Connections
  3. Select SmartThings and follow the prompts

From a quick look at the logs, SmartThings is complaining that the musicPlayer capability isn’t a valid capability. Looking at the device details in SharpTools, musicPlayer appears to be valid, but it’s a capability that SmartThings has been trying to deprecate, so if they migrated the device to an Edge Driver, they very likely moved it over to the new mediaPlayback capability (and other mediaXXX and audioXXX capabilities).

In that case, resyncing the list of devices should clear things up for the dashboard. Depending on when you created the rule, you might have to edit the rule and reselect the command to update it (after the device sync).

1 Like

Thanks. I reauthorized and that was the primary issue although the volume no longer functions like it used to. Everything functions with the exception of the volume which does not respond properly to the level. Everything is very quiet even at 100% volume level. Any thoughts on that issue?

In the dashboard or in your rule?

I am not sure what I am seeing. I will describe it. I can use the Sharptools dashboard to manual set the volume via the media player. The command says it is sent and is green. When I look at the smartthings dash for the same media player, it shows the change I made manually in the in the Sharptools dashboard. When my rule fires, it sets the volume but that does not appear to be reflected in the Sharptools dashboard or the Smartthings media player. Whether I set the volume manually or not, the sound file always sounds very quiet and doesn’t seem to be controlled by the volume at all.

For this part, make sure you tried the steps I mentioned above about editing the device action within your rule and reselecting the command. I would try selecting a different command and then reselecting your setLevel() command. If that doesn’t work, you might have to recreate the device action block.

If the volume level on your speaker doesn’t seem to change when manually adjusted from your SharpTools dashboard or within the SmartThings mobile app (even while you have music playing), that might be an issue with the device driver itself.

I would make sure to separate the test of manually controlling the volume and confirming if that works from a test of running your rule just to make sure we really know what is and is not working.

I was able to fix the problem. Apparently, there is no longer a Set_Level command but instead there is a Set_Volume command. I updated the rules, per your suggestion, to use the Set_Volume command and everything seems to be working again. To summarize then, I corrected the problem by first reauthorizing all my devices between SharpTools and SmartThings, and then I updated the rules to use the new Set Volume command instead of the deprecated Set Level command. Thanks very much to Josh and Nezmo for your assistance!