Blue Iris Stream Stopped Working

Hello, I have had my BI stream working in SharpTools for quite some time. In the past week or so, the resource no longer loads.

I can browse to the resource just fine in Chrome and in Edge.

This is all local on my network and in the same subnet. I have tried with the firewall on and off on the BI server. What is confusing me is that I can access the resource no problem in the browser. It is just from SharpTools that it does not work. Has anything changed recently in how these function?

I have reviewed other posts in regardss to this setup and they all focus more on getting it to work to begin with. I am already past that point. Any help would be greatly appreciated. Thanks!

No changes with how the Media Tiles work recently.

Has your Blue Iris version, or your browser version, or something else changed recently? And have you checked if it’s a Mixed Content issue?

Hi Josh, I am on the latest version of BI. I can look into updating to using HTTPS with an SSL cert. Since I am on the local network and the browser displays the content just fine, i am confused as how one would work and not the other. Thanks!

When you view an HTTP resource directly in your browser, Chrome allows it but displays the ‘Not Secure’ message to the left of the URL bar.

When you embed HTTP resources in an HTTPS page, older versions of Chrome allowed that ‘mixed content’ and just displayed a warning in the browser console. Starting with Chrome 85, the browser tries to automatically upgrade the content to HTTPS (if available), otherwise it blocks the non HTTPS content.

Just for testing, you might just try disabling the Mixed Content Blocking in Chrome on the desktop per the linked article just to see if that fixes your issue. If it does, you can decide if you want to leave it with mixed content enabled or if you want to add SSL to your Blue Iris setup.

What is your BI web browser’s authentication settings? Ex: " Non-LAN only", so it doesn’t need authentication if the request is coming from the local network. Just another though if it is authentication related issue.

1 Like

Thanks Josh. That fix worked. I will look into getting SSL setup correctly.

Hi James, I do have the auth settings to Non-LAN only. Thanks!