Beep on screen touch - Fully kiosk? Possible?

I just replaced the computer driving my touchscreen from a Windows based system to Android-X86. I am running fully kiosk. The android OS makes a nice subtle been on screen touch. This also works in the fully kiosk menus. But it does not work when using the browser screens in fully.

I can’t find a setting to turn on the beep in fully. Is this a CSS control or something else? Thanks

Not sure if it’s what you’re looking for, but there’s a setting under:

Fully Kiosk Browser settings > Web Browsing Settings > Enable Tap Sound

Thanks. That is on. It sounds great in the fully kiosk menus or in the Android OS but becomes almost inaudible when browsing sharptools. There is a faint click in the background.

There is a volume control under devise management. I don’t understand how it works. It says you can set stream:percent. I have no idea what it is looking for here or if it is even relevant. I tried a couple of things but nothing improved the level of the sound. There is nothing documenting this that I can find.

Incidentally. When I load chrome I get screen tap noises on all sites until I go to Sharptools?

What make/model device is this and what setting did you enable to get tap sounds throughout the OS?

Can you share a screenshot of what you’re referring to with the volume control under device management? Perhaps someone in the community has experience with it.

I got it. Posting information in case someone else needs this. A little bit of RTFM more thoroughly.

I am running Android.X86. Latest 9.0 r2. Running on intel NUC - I have i3 and i7 units so far.

The OS system click is nice and loud and works in the Fully Kiosk menus. But when you go into Webview in Fully, the click is gone. Then you can turn on the Fully click in the Web Browsing Settings. It was there but barely audible.

As mentioned before, there is a volume control setting in Device Management in Fully. The documentation is below. I had guessed at some of the settings but was shooting in the dark a little. So I decided to set everything to 100 - 1:100,2:100, 3:200 etc. I am not sure which of the items in the list did it - I suppose I could figure it out by process of elimination.

  • Set Volume Levels (PLUS) – set initial volume levels when the kiosk app starts, comma separeted stream:percent list, empty for no change. Stream codes: 0 – Voice Call, 1 – System, 2 – Ring, 3 – Music, 4 – Alarm, 5 – Notification, 6 – Bluetooth, 8 – DTMF, 9 – TTS, 10 – Accessibility. For example, the string value 2:80,3:50 will set the ring stream volume at 80% and the music stream volume at 50%.

Interesting. It sounds like this feature is basically overriding the default audio streams in Android.

Historically, many of these audio streams were exposed in the Android volume adjustment window. I think Android realized that this was overwhelming and confusing to the mass market, so they’ve simplified everything down to one main volume control.

But behind the scenes, many of these ‘streams’ are still individually adjustable. It varies from device to device as each manufacturer seems to customize the ‘skin’ on top of the Android OS, but in general you can find it in your main Android Settings > Sound and Vibration.

For example, here’s was a Pixel 4 looks like:

Yes, basically the same settings in Android.X86. Fully Kiosk web view is definitely overriding these. Either nothing, if tap to click in Fully settings is turned off, or a different click sound when tap to click is turned on.

1 Like

A few months ago I wrote Fully Kiosk Support about my experience with the “tap” sound.

I have five Fire 10’s:
Two older (micro USB port); both “click”
Three newer (USB-C port); only one of them “clicks”

We determined that the tablets were at various versions of Fully software.

This is the response from Fully:

Hello Stan,

You are using obviously different versions of Fully Kiosk Browser on every device. If you say that 1.42.2 makes a good sound, try using it on other devices as well.
You will need to uninstall the app in order to make a downgrade.


I followed that advice and my tablets are “playing taps” now. The sound level varies from tablet to tablet, and I would rate even the loudest one as faint.

1 Like

I can confirm that I am on 14.3.5 fire and setting the volume as described above does the trick on my devices - one current HD8 and 10, and two older HD 10’s. Incidentally does anyone know if there is a setting to auto update or at least warn when new versions become available for Fully? I don’t see a setting - I am sure it is right there in front of me.

P.S. If you have the time to figure out which of the volume settings is the screen tap sound 0,1,2,3,4,5,6,8, or 10 please post back! Thanks.

I’m not aware of this capability. I believe that you would need to check their website for the current version.

Unless I’m having a problem i follow the adage “if it ain’t broke, don’t fix it” and don’t routinely seek updates. It’s even possible that a newer version could be less desirable - as I experienced with the tap sound situation.

BTW. It is 8 DTMF that controls the beep for the fully kiosk menus and 3 the beeps when touching screen in sharptools. Finally took the time to figure it out.

1 Like