Background images not loading

I have a dashboard that used to load background images (via URL) just fine but it isn’t working right now. I’ve tried both the original, local (to my network) URL and a random public image I’ve found on Google and both have the same error. Any thoughts?

@tagyoureit, can you please post the image URLs you have tried? and try if the image loads when opening the same dashboard on your mobile phone without connecting to the same wifi network? (Trying to narrow down if the issue is limited to the network or device.)

Thanks for the quick reply… some interesting results. And I should note I’m on the Beta site. That probably makes a difference!
So, very strange, I created a new dashboard and it loads the bg image properly.

My phone loads an old image which I’m guessing is cached, but it doesn’t load the current image. I tried to change it on the mobile phone and it doesn’t work (loads same image, but no error).
(Wrong image showing…)

I tried both incognito mode (for a fresh cache) and the regular browser and the image below doesn’t load. (Error screen as above.)

Here’s the image I tested:

Keep in mind that there are two different places that you can set a background image for a dashboard.

  • Theme - Background Image
  • Dashboard Settings - Background Image
    • Hidden under the ‘Advanced’ toggle (unless it’s already set)

The Background Image option in the Dashboard Settings will override the Theme setting. This allows you to set all your general preferences in a Theme, but still provides the option to override the background image on a one-off basis if needed. So if you still had a Background Image set in the Dashboard Settings, that one would win out and attempt to be displayed.

If you have a Background Image set in the Dashboard Settings, you’ll see a check next to the image icon. You can tap that, scroll down, and select ‘Clear Selection’, then save your changes.

1 Like

I tried the world_map in both approaches mentioned by @josh, and both worked for me. As @josh pointed out, you will need to check the background image setting is not overridden by an incorrect image url/media source. (You can also verify by creating a new clean dashboard and use the map image as the background to verify it works first.)

Ok, thanks guys. Somehow the dashboard version of the Media (User) image/url was corrupt and not showing. Once I selected a different one (or subsequently a theme) it worked.

Is there a way to delete “Media (User)” items once they are created?

@tagyoureit, you can edit/delete the Media Resource at the Resource Management page.

Oh, don’t think I knew that page existed. Thanks!