Annke NC800 Snapshot Error on Tile

I have Annke NC800 (Hik Vision) Camera, I’ve been trying to get a snapshot as a tile for days now but it doesn’t work.

He always said that there are problems loading.

I also tried Fully Kiosk because of Mixed Content but that doesn’t work either.

In the browser the snapshot link works without problems

The snapshot link looks like this

Anybody got an idea?

In the meantime, I get an image once with Firefox browser on the tablet, but only until the refresh comes then it is gone again.

With Fully Kiosk no chance to get a picture. Despite changing the user agent and mixed content

You didn’t mention your browser / webview version, but make sure to pay close attention to the Chrome 111 note (and the suggested workaround) in the following post:

As for your second URL format, note that many browsers block that format:

I have also tried Firefox.

Now and then I get a picture or a stream but it doesn’t stay for long and then it’s gone again.

The links from you I have read both

Thanks for the update. It’s a bit hard to help without knowing exactly how things are configured, but I’m going to make a few educated guesses based on what you described so far.

TLDR: You’re likely dealing with a finicky camera implementation paired with some common browser restrictions. The browser restrictions are generally easy to workaround, but the camera implementation might be making it seem harder than it should be. If the camera fundamentally doesn’t offer the options you want, the easiest choice is usually to setup software like Blue Iris or TinyCam to proxy the image stream.

1. Embedded Credentials

As noted in the Camera with username and password embedded in the URL help article, I would check to see if your camera has a different option for authenticating or consider a software solution like Blue Iris or TinyCam.

Many browsers have begun blocking embedded resources that have the credentials at the start of the URL. For example, many cameras allow passing the credentials as parameters which works around this.





If you find suggested URL formats, I would recommend trying them directly in your browser first. If they don’t work directly in your browser, then they won’t work as an embedded resource within SharpTools.

An alternative approach is to use Blue Iris or TinyCam which have other options for proxying access to your camera streams that don’t require embedding the credentials at the start of the URL.

2. Mixed Content & IP vs. Domain

As noted in the Chrome Mixed Content article, some modern browsers have begun blocking mixed content by default. The article has some steps on how you can enabled mixed content in various browsers.

Fully Kiosk Browser ▸ Advanced Web Settings ▸ Mixed Content Mode: Always Allow Mixed Content

Additionally, recent updates to Chromium compatible browsers have a bug that ignores the Mixed Content settings for IP addresses. As a workaround, you can use our experimental Domain to IP service.

You can update your camera address to the format:


Something like*:

*As noted in item 1, the first thing you would need to figure out is the embedded credentials.

3. Autorefresh Compatibility

Since your URL seems to point to a static image snapshot and you mentioned that the picture doesn’t stay long, I have to assume that you are using the ‘Autorefresh’ option.

Some media sources don’t like the ‘force refresh’ feature, so you might need to disable it. Again, this brings us back to a potentially finicky camera implementation. If the camera doesn’t support either the ‘force refresh’ setting or send across the proper cache headers, the ‘Autorefresh’ option might not work as expected: