Android Fully Kiosk Color Issues

Hi all, I am seeing a very odd issue with colors of icons on my dashboards. On my desktop browser the color is black. On my android tablet in chrome they are also black.

However, in Fully Kisok browser, on my android tablet, they are white. These specific tiles have no background and black color for the icons. It is also using a background image.

I don’t even know where to start looking. Any pointers much appreciated. I am assuming this is a Fully Kiosk issue but could find no related settings.

Can you share some screenshots demonstrating the working and broken instances?

The dashboard or the tiles have a background?

Are you using Custom CSS in the impacted dashboard theme?

Yep, good idea.

So (Yeah, black might not be the best choice but still …):

  • Chrome on PC:

  • Chrome on Android:

  • Fully Kiosk on Android:

And here is the black’ icon setup in my theme:


It sorta looks like the browser is merging all three layers? Not sure why black would become white but the underlying image certainly changes (some) of the colors?

I have no custom CSS.

Some colors and opacities vary depending on the device I’m viewing it on.

For example, viewing a dashboard on PC / Edge or Android tablet / Fully Kiosk Browser looks as expected. But Android phone / FKB looks different; tiles that should be 90% transparent are solid white and other tiles that should be yellow are black.

My two screenshots show the UV Index tile looks different and all the sensor status tiles are different too.

I haven’t tried hard to resolve it, but I did find that playing around with the color picker in SharpTools, I could find combinations that work well on all devices.

This is what it looks like on my Android phone using FKB.

This is what it looks like on my PC and Android tablets:

Yeah, I think it’s just ‘the way it is’ :-(. I’ll just play around with the colors to get what I want on my tablet/phone. It’s a little odd that its fine in Chrome on the tablet but not in the Fully Kiosk browser. Fully Kiosk uses android system webview which maybe the issue? Not sure.

I’ll report here if I solve anything!

1 Like

Well, Fully responded – I turned off ‘dark mode’. Well actually forced it off as it is the ‘system mode’. Fixed the issue. Full on Android now is the same as Chrom on android and PC.

Nice one Fully.


Forcing Dark Mode off fixed it for me too. Strange how Dark Mode turned nearly completely transparent tiles bright white.

Thanks for passing along the fix!

1 Like