Alarmsystem and PushBullet

Hi guys

So I’m trying to make an alarm system, lite, with the things I have at the moment. Which is just a few contact sensors.

But I’m having some issues with how to get notified of an alarm.
I now get a PushBullet message, with the location that triggered the alarm. But that’s just a notification, not like my phone starts ringing or whatever. Just a short sound and that’s it.

Is there a way to lengthen this?

Secondly I wanted my tablet to start playing a siren. I tried to send Fully Kiosk a URL with remote admin through the FK DTH, linking to youtube. But Fully Kiosk doesn’t react to anything I try to send it.
It does react to going to the same URL from my phone.

Is there any alternative way to make it go loud and sound an alarm? I haven’t tried putting a siren file on the tablet and just calling siren or alarm yet. But haven’t got a lot of hope for that, since the openURL doesn’t work either.

Pushover has seem neat options around ‘alarms’ that you might be interested in. They have a concept of message ‘priority’ where a High priority message will bypass your quiet hours and emergency priority (‘Highest’) which will also repeat until the notification has been acknowledged.

Can you share more details about what you tried in each case? If you’re using the Fully Kiosk Controller (DTH), you should be able to use the playSound() command or the siren() command* in a rule with a valid URL to a file.

* Note that in order to use the siren() command in the Fully Kiosk DTH, you have to configure the ‘Siren Audio File URL’ setting on the Thing.

Example using playSound():

Example using siren():

Where the device preferences (in this case, in Hubitat) have been updated accordingly:

I can’t find any priority settings in pushbullet. I can set sounds for different priorities, but I can’t see anywhere how to set a push message to be treated high priority.

The FK issue, could it be because it also keeps telling me “checking” in Smartthings? I read about some issues with the handler in newer versions of the app.



Apologies if I didn’t emphasize it in my original post, but I was talking about Pushover having these features, not Pushbullet.

Pushover is another app, similar to Pushbullet, that has the ability to push notifications down to your phone. Unlike Pushbullet which is free for 500 notifications / month, Pushover has a one-time fee of $5 for each platform you use it one (eg. iOS, Android).

Have you made sure that you set the appropriate preference within the device in SmartThings? In SmartThings, I believe the preference is called ‘Alarm Audio File URL’.

Or tried the playSound() command and pass the URL to your MP3 file directly?

Oh sorry, I completely missed you wrote pushover, not pushbullet. Whoops!

I now tried a different handler, but I think I’m just setting it up wrong or something. It keeps showing offline, can’t seem to find it. All other ways to remotely let FK do something works, but not through Sharptools/Smartthings.

I have set a url for a siren, if I simply send it to loadURL with remote admin it plays fine. If I set loadURL in my rule, nothing happens.

The ip and pass are set, only thing I can think of that might be wrong, is the device network name in the handler. Tried different things, to no effect.