Unable to add Hubitat


#1

When I try to pair Sharptools to hubitait say Opps no authentication


#2

@Gary_Adkinson thanks for posting. The most common cause of not being able to authorize Hubitat is the hub not being connected to the Hubitat cloud relay. And the most common resolution is to simply reboot the hub and then wait several minutes after rebooting for things to settle down before trying the authorization again. :grinning:

You can find more Hubitat Authorization troubleshooting steps in the following article:


#3

Tried everything I know. No computer wiz. Says no HUB ID


#4

Thanks for the additional details. “No Hub ID” is an error message returned from Hubitat and means that there isn’t a hub associated with the credentials that were used to login to Hubitat.

This message typically means one of two things.

  1. Incorrect Hubitat credentials were used - try authorizing again and double check that you’ve used the same credentials that were originally used for setting up the Hubitat hub. (I’ve used the wrong Hubitat credentials more times than I care to admit)
    Note: sometimes it’s helpful to try this in an Incognito window for your browser since Hubitat caches the credentials for a short period
  2. Hubitat doesn’t have a Hub associated with your account. If this is the case, you’ll need to reach out to Hubitat support so they can get the hub associated with your account.
    support@hubitat.com

#5

I’ve gotten exactly the same error message!
Is there anything wrong?
I’ve rebooted, and tried to login again with the same id.
I’ve got cloud connectivity to my Hubitat.
???


#6

Furthermore, when I tried to change the password on my account, I went through the “forgot password” approach.
Sharptools wouldn’t send me an email to change my password!


#7

Jack, if you are seeing the ‘No Hub ID’ message, then my notes above apply. It means there isn’t a hub associated with the credentials used to login to Hubitat which means either the incorrect Hubitat credentials were used or Hubitat doesn’t have a hub associated with the account (and you’ll need to reach out to Hubitat support).

Note that ‘No Hub ID’ is a specific message returned from Hubitat and is different than a generic ‘Uh Oh! We couldn’t complete the authorization’ message.

Have you tried reauthorizing IFTTT and/or Alexa/Google Assistant in Hubitat? Both of these use a similar authorization flow as SharpTools, so it’s a useful tool to compare against.


#8

Just to confirm, from the SharpTools.io email login flow, you entered an incorrect email/password, then clicked Reset Password, then clicked Send and saw a message that says:

Reset Link Sent

Follow the instructions sent to email@domain.com to recover your password

If so, I’d also recommend checking your spam folder to make sure the password reset email didn’t get caught there. I checked with our email delivery service and it shows the message as delivered, but it could still have been incorrectly caught by a spam filter.

I just went ahead and initiated a password reset email for you on your behalf, but you’ll still need to complete the steps in the email to complete the password reset. Also keep in mind that if you have any other logins linked to your SharpTools.io account, a password reset may unlink those accounts and you’ll have to relink them after the password reset. :slight_smile:


#9

Hello.
I rebooted my Hubitat.
I deleted my sharptools app in Hubitat and reloaded it.
No difference, still can’t get in to re-authorize Sharptools from Hubitat.
Any suggestions?


#10

Jack-
I’m not sure I ever saw an answer to the following question.

Edit: I took a look through the logs and I’m seeing the following during your attempts to authorize Hubitat indicating that the Hubitat server is returning an error.

Platform hubitat error: HTTP Error 500: Internal Server Error

I’d be interested to hear what the results of attempting to authorize IFTTT and Alexa/Google Home on your Hubitat account are. We will likely need to escalate this with the Hubitat support team and having that info will be helpful in diagnosing.


#11

I unlinked my Hubitat from my google home app.

I rebooted my Google home.
I cannot re-add (link) my Hubitat to Google.

Now I don’t have a google home connection, as well as a sharptools connection.


#12

I’ve escalated to Hubitat Support. I will copy you on the emails…
We shall see what the issue is…


#13

Got my Sharptools linked finally.


#14

How did you get it to work?


#15

Had to contact Hubitat get the original email I used. Went back logged in with it worked like a charm. Bobby at Hubitat had asked for Hub ID then sent me the Email I used when I bought the hub. I had used a different email to set up my hub, worked for my hub but not for Sharptools link.


#16

Is there any way for a user to remove/delete a connection to a hub on our own?
(e.g. Hubitat, SmartThings, etc.)


#17

Yes. For SmartThings, just proceed through the authorization process as normal and after you’ve selected your desired location, scroll down and tap the ‘Deny’ button instead of the ‘Authorize’ button. That will redirect you back to SharpTools displaying a warning and in the background it will unlink the account.

Hubitat is not providing the required data for SharpTools to know which location was unhooked when ‘Deny’ is pressed. You can shoot a note to support@sharptools.io and we can unlink a Hubitat account for you.

That being said, SharpTools will automatically remove any unused locations/things and add new locations/things during a successful authorization. Considering that Hubitat is fundamentally returning an error message during the authorization process for you (even with Google Home), manually removing the location/things from the SharpTools account wouldn’t help in this particular situation.


#18

OK.
Can you please unhook [redacted] in Hubitat from my account: [redacted]?


#19

@Jack_Weinberg I’ve removed the location and associated things as requested.