Sharptools routines

Hello everyone. I have a problem with sharptools for android. So I have no routines in smartthings anymore, however I show 4 routines in sharptools that dont exist anymore, and I cannot get rid of them. Also, when I create one in smartthings, it doesnt show up in sharptools. Ideas?

Thanks for the message and sorry to hear that things aren’t working as expected.

Just to confirm, you are using the SmartThings Classic app, right? The SmartThings Classic app is the only way to access and create Routines in the SmartThings platform. The new Samsung SmartThings app only has access to Scenes.

Once you’ve created or updated a routine in the SmartThings Classic app, you’ll need to manually refresh the list of routines in the SharpTools for Android app.

  1. Open the SharpTools for Android app.
  2. Slide out the left navigation and select Routines
  3. Tap the refresh icon in the top action bar

If that doesn’t work, can you provide a screenshot of what you are seeing in the SmartThings app and a screenshot of what you are seeing in the SharpTools app?

I am having a similar problem here – I used to be able to trigger Smartthings Routines via the SharpTools Tasker plugin but this no longer functions correctly. I will mention that I had (of course) to go back to the Smartthings Classic app for Android, once I realized the new app (which I didn’t like anyhow!) no longer implements Routines. I have tried recreating the Smartthings Routines and following all the recommendations made in the post to which this is a reply – but no change. I also tried completely removing and reinstalling the Smartthings Classic app – did not help. What am I missing here?

Did you recently get presented with the option to migrate from SmartThings Classic to the new app? If so, it replaces all your Routines with Scenes. Once your last Routine is gone, there’s no way to get them back.

That being said, you can use Virtual Switches or Modes to trigger your Scenes:

Wow, you are really fast in replying, Josh! In answer to your question, I never used the migration tool or even knew it existed. I had just installed the new Smartthings app alongside the Classic one. So … are you saying that I do NOT have the option to remain using the Classic Smartthings app? Meanwhile, I do know about Virtual Switches and will give that approach a try – it is not ideal because it creates something of an execution lag. (Honestly, moving from Smartthings to something like Hubitat is becoming a lot more attractive to me!) Thanks again very much for your fast reply – I am impressed!

Do you still see the Routines in the SmartThings Classic app?

I do still see the Routines. But, interestingly, when I looked inside of them, they were no longer triggering the desired Scenes (to change colors on a couple RGBW devices). I fixed the related routines and now everything works the way it used to in the related Tasker app. I’m not sure how the Routines got screwed up, but it is advantageous, because I’ve learned a great deal from you today, and can see that I have a bit of reading to do to catch up, thanks!