Rules and dashboard switching

I was using the FKB controller with SmartThings to switch dashboards based on rules.
That FKB device no longer seems to be working and with the upcoming depreciation of the IDE I am looking for alternatives.

Is it possible to use a rule that:
If xxx device changes to on
Then make HTTP request to xxx dashboard url?

I tried using the HTTP get with SharpTools App but it doesn’t execute

Hi @Terri, do you mean using Rule HTTP Action to make HTTP request to your tablet running Fully Kiosk Browser directly? Yes you can do this without the need of FKB device handler, but you will need to configure your router/gateway to direct the traffic from internet to the tablet on LAN securely.

See below for a quick Fully Kiosk Browser’s api example. Because your tablet uses a local ip address, the HTTP request sent from Rule Engle will not be able to resolve and reach your local ip address. So you will need to configure your router/gateway to forward the external traffic to your tablet and use an external reachable address in the Rule HTTP. (Please make sure your setup is secure and encrypted.)


I’m not sure how to set this up. Is there another way to achieve my goal or can you point me to instructions so I don’t mess up my router?
Sorry, I’m still learning and while there is a lot I can do, there’s even more I haven’t learned yet. :sweat_smile:

Can you share more details about what isn’t working with the FKB Controller integration?

That’s normally the easiest path for this sort of thing.

I had rules set up that called dashboards using the FKB device from ST. They all worked until about a week ago. Nothing in the rules has changed and the dashboard url’s have not changed. They just don’t execute any longer. But with the IDE going away sometime soon, I was looking for an alternative anyway since the FKB DTH stop working.

What about the device running Fully Kiosk Browser? Does it have a static IP assigned to it? If not, it may have picked up a new IP address which would cause the integration to stop working.

No. I’ll check that and report back

That was the first problem. The IP address had changed. I updated the IP and reserved the DHCP on my router. I confirmed devices work by testing tts in fully remote admin.
However, the rule that when a switch changes to On, show Dashboard is still not working.

Did you test that the FKB ‘device’ from SmartThings was able to send commands? If you haven’t already, you’ll need to update the SmartThings ‘device’ configuration with the new IP as well.

If you are able to send commands from the FKB ‘device’ in SmartThings and your rule still isn’t working, can you please either share a screenshot of the rule or send a PM to @support with the Rule ID so we can take a closer look at how the rule is setup?

I just added a tone to the FKD device and it is not working.

My rule

Hi @Terri, the toneFile link should be ended as “dl=1” so it can directly access the file from dropbox.

Once you corrected the toneFile link, follow the instructions here and tap the “Find sensor” button to test if your tablet plays the bell sound. If so, it is connected. Otherwise, you may want to open the Live Log in SmartThings IDE to watch if there is any error when you run this rule or tap the “Find sensor” button to get a better clue what was causing the issue. ( You can change the log level from the FKB device page → edit Preferences as shown in your screenshot.)

I got it working.

  1. changing the dropbox 0 to 1 worked :+1:
  2. I had entered my wifi password instead of my server password! :woman_facepalming:

Thanks for your help!

1 Like