Linking w SmartThings

Trying to link SharpTools with ST

Getting network not found error within SmartThings.

Good to hear from you and sorry to hear that things aren’t working as expected.

Can you share a screenshot of the error message you are seeing?

And just to be clear, are you trying to update your SmartThings connection by following these steps:

  1. Open your User Page
  2. Tap the Manage Connections button
  3. Select Samsung SmartThings and follow the prompts

Thanks for the response.

I’ve tried the steps outlined, both from my phone and my Samsung tablet

Each time I get the same error.

Screen recording to follow

Sorry for the delay, I initially did a screen recording and had to edit it to allow me to upload a jpg
Sharp Tools network error

Thanks for the screenshot. I’m not sure I understand why you are in the SmartThings mobile app though? :thinking:

The steps I listed above start from within the SharpTools web app and shouldn’t lead you to the SmartThings mobile app.

The SharpTools item at the bottom of your screenshot looks like the old Groovy SmartApp which isn’t used anymore. You can safely delete the legacy Groovy SmartApp as the connection uses the new SmartThings APIs now. You must use the steps I mentioned above to authorize (or reauthorize) SmartThings to SharpTools.

Thanks for the clarification.

I’ve now deleted my prior ST connection and re-established a connection to ST.

My confusion arises from the fact that when I open SmartThings and try to activate SharpTools within the Automation Category, I am still getting the No Network error message.

Am I missing a step?

Could you please provide more information on how you deleted the prior SmartThings connection? Just to clarify, the Groovy SmartApp is no longer supported and should be removed.

Here are the steps to delete the Groovy SmartApp:

  1. Open the SmartThings mobile app.
  2. Tap the Automations tab at the bottom.
  3. Scroll down to the SmartApps section (if necessary, expand it).
  4. Long press on the SharpTools entry and select the Delete option.

Regarding the issue you’re facing, it seems that the discontinuation of the Groovy platform by SmartThings may be complicating things. SharpTools no longer utilizes the Groovy SmartApp, and Groovy SmartApps are no longer functional due to SmartThings shutting down their Groovy platform. Although several remnants of Groovy SmartApps are still visible in the mobile app, SmartThings likely kept them for reference purposes during the transition to new versions of those apps.

For further details on this, you can refer to the original Groovy Shutdown announcement thread; however, most of the information provided there may be outdated as the migration process has already been completed:

:link: SmartThings Groovy Shutdown Announcement Thread

In the case of SharpTools, our new connection is considered a ‘Linked Service’ and can be found deep within the SmartThings app settings. To authorize your SmartThings connection starting from your SharpTools User Page, please follow the steps mentioned above.

To view the Linked Service, please follow these steps:

  1. Open the SmartThings mobile app.
  2. Tap the ≡ Menu option.
  3. Tap the :gear: icon in the top-right corner.
  4. Select Linked Services.

You should see SharpTools listed under one of your locations, and if desired, you can ‘Unlink’ it. To establish or reestablish your connection, please refer to the steps mentioned above.

It appears that SharpTools is now included in Linked Services.

I will work on activating one or more of my rules and see if SmartThings responds appropriately.

thanks for your assistance

1 Like