How To Authorize Unrecognized Things

@Shane_Rock today’s platform update includes support for custom attributes in Hero Attribute tiles which means that all attributes should be available in the Hero Attribute tile now.

More Details: Fade Level and Custom Attributes

Note that for Hubitat users, a related SharpTools Hubitat App update is currently available in the Hubitat hub beta release 2.0.6 and working its way to production release.

When viewing your location details in, you’ll now see a Show Advanced switch which can be toggled to show the SharpTools app version reported by your hub. For Hubitat, you’ll need to be on at least version 5.2.0 (12) to take advantage of the dynamic subscriptions.

working great thanks!


An old post, but will try anyway.
Have added a Brunt blind motor, it appears in ST and in the ST API, but not in SharpTools.
I have already migrated from the Classic App.
Is there another way to get the Brunt to appear in SharpTools??

The steps listed in post 2 of this thread work in the ‘new’ Samsung SmartThings app now:

Edit: I’ve updated the post with steps for the new app instead of Classic so it’s more clear moving forward.

Have tried the additional items 3 options, but the Brunt blind motor does not show there.

I’ll send you a PM to see if we can gather more details. As the instructions note in the post above, the device has to either support one of the core capability types (eg. Switch, Contact Sensor, Temperature Sensor, etc) or report one of the generic capabilities of either Actuator or Sensor.

If it doesn’t report any of those, then you won’t be able to authorize it directly.

As a workaround, you might be able to create a virtual device like a virtual switch and use that as a proxy for controlling your other device. (eg. create the virtual switch, setup an automation in the new SmartThings mobile app that when the virtual switch is turned on then open the blinds for example, then authorize the virtual switch in SharpTools)

I’m having difficulties with my First Alert Smoke detector and IKEA blinds. I have gone into the other devices in the new app and the Classic app. I then go to authorize and they do not show up. Both of these were previously there and used in numerous dashboards. Now the dashboards show a “placeholder”.

Hi @Dale_Huber, devices not showing up in the device authorization list because they don’t have any core capability supported in SharpTools implemented. In this case, you can still authorize them by following the steps in the post below as long as they at least have either Sensor or Actuator capabilities implemented. Once your follow the steps to authorize them again, those placeholder tiles should resume to how they looked like before.

Just to clarify, once you’ve added those ‘Additional Devices’ selections via the SmartThings Mobile app, those devices should automatically show up in SharpTools.

In other words, you don’t need to go back through the authorization process starting from your User Page. If you do, the more limited set of authorizations from the web authorization flow override the ones from the mobile app (it’s a bit of a quirk with the SmartThings authorization flow).

Sure enough, when I looked they were there. Thanks. Sooner or later I’ll get the hang of this.

1 Like

@josh Hi, I just added some virtual humidity sensors in Hubitat and wanted to show those in Sharptools. I am tracking the humidity in my basement. I can’t seem to find it in any of the hubitat device sections including the Additional Devices?

If I remember correctly, several of the built-in ‘virtual’ devices in Hubitat only implement their core capability and do not implement the Sensor or Actuator capabilities for whatever reason.

You could adjust the driver to add the Sensor capability though. For example, here’s a Virtual Humidity Switch driver I just put together. It also adds the Switch capability (which you can ignore or remove if desired) which makes it even easier to authorize:

Thanks - I played around with this and ultimately landed on using virtual temperature. It was cleaner and I was able to adjust the units on the tile to show %.


Thank you, that worked out for me.

1 Like

I have recently installed a Shelly Pro 3EM Energy monitor on Hubitat with the Community drivers. All the child devices were successfully created when it was configured in Hubitat and all works well within Hubitat. However in Hubitat when trying to allow access to Sharptools, not all the Child Devices are visible to tick off under the Sharptools App. Only the Temp sensor is available to tick under Temperature Sensors and the Parent Device under Additional Devices. None of the other Child devices shown on the screenshot are visible to Authorise.
My Sharptools Version Name is 5.3.1 and Version Code is 14. Hubitat platform version is now (I found my Hubitat hub software was fairly outdated when I was pulling this info, but is now updated to the latest version but still without sucess of seeing all the Child Devices in Sharptools).
I have tried the suggestions in this thread to try and resolve the issue but without luck and now after some suggestions to fix the issue. As an aside and not sure if related, I can see all the Child Devices when authorising Webcore (on webcore app in Hubitat) to access these devices and all the Child devices attributes are visible in Webcore.