Google Chrome - Mixed Content - Media Not Showing

Did google start blocking this again? I allowed mixed content but i still cant get it to work.

Check out this post as the Chromium 111 update may be impacting you. It includes some workarounds…

Google Chrome - Mixed Content - Media Not Showing - #9 by josh

I just started having this issue; image shows in manage resources, but not on dashboard. https was disabled and mixed content was enabled in fully kiosk. i even tried using https and get the same issue. this is a new fire tablet 8.

If it works in managed resources on the same device and browser, then it should work on the dashboard as well as they display the media resource the same way.

One difference on the actual Media Tile is if you have the Autorefresh enabled. When the media item first loads, it’s exactly the same as the Manage Resources tab… but once the refresh interval occurs, it will append an arbitrary URL parameter as a cache buster technique.

Since you mentioned that you already have the setting to allow mixed content enabled in Fully Kiosk, I would pay particular attention to the Chromium 111 bug mentioned above as many modern web browsers are based on that… check the reply above about using nip.io as a workaround.

Edit: If you are using Blue Iris, you might also check this post about embedding Blue Iris streams in a much more efficient way.

I misunderstood the nip.io workaround and thought it involved adding things or creating an account of some sort. So tried the much more efficient way, but that bothered me you can’t make it full screen. I really liked you could see all camera’s in 1 tile, but tapping a screen didn’t make it large enough.

So then I looked at the nip.io again and that was easy, just add it to the IP and done :sweat_smile:
At least now my tablet can simply update instead of running an old webcore. That’s how I used to do it, but suddenly my tablet decided to update anyway and broke it again.

1 Like

Still having the issue - mixed content set to always allow on fully and origin ip added to chrome flag. Video loads in browser and media resources but not fully kiosk. Nip.io didnt work (broke preview in media resources). Anything else I can do on Fire tablets?

1 Like

Fully kiosk must have just recently updated to chrome 111. If anyone has a link to an older full kiosk I’ll take it but for now, Thanks! npi.io solved my pic from my camera streams but to access my camera streams in the ip address I have my user and password for the camera, how secure is nip.io? as secure as sharptools or actiontiles I suppose

Edit: As jordan stated video doesn’t work but I did find old apks https://apkpure.com/fully-kiosk-browser-lockdown/de.ozerov.fully/versions so I’ll try to side load an old full kiosk browser

ugh, am i gonna have to install the play store on my fire tablets? or can i sideload apks an easier way? this is becoming a hassle for one video feed on my home dashboard…

Why do you need to sideload an APK? You should be able to view media tiles even with the Chromium 111 update, but you would need the mixed content and nip.io approach. You mentioned that things weren’t working in Fully Kiosk with nip.io, but it wasn’t clear what you had tried as that should work.

Maybe you could share some screenshots of:

  • The working media URL in a regular browser (with the URL visible)
  • The configured media URL in Fully Kiosk using the nip.io format not working in the preview in Manage Media

the only thing i havent tried is the aforementioned old apks for fully or browsers. for nip.io, the new address just didnt do anything and using that actually broke the preview within sharptools when editing the resource. i dont have access to it now, but ill post screenshots.

The only thing that passes through nip.io is the DNS request for the subdomain. The rest of the URL does not get sent to nip.io.

In other words, your browser only sends the domain name 192.168.1.50.nip.io to nip.io and nip.io responds that it’s available at the IP address 192.168.1.50. From that point forward, anything else in the URL or the request gets sent directly to the IP address (eg. your camera).

The flow looks something like the following:

  1. Your browser gets a request for http://192.168.1.50.nip.io/mycontent
  2. Your browser sees that the request is a subdomain of nip.io, so it asks nip.io where it can find the subdomain 192.168.1.50.nip.io
  3. nip.io replies that the subdomain is available at the IP address 192.168.1.50
  4. Your browser then makes the http request to the provided IP address along with the rest of the URL (eg. at this point, the full path of the URL gets sent to the IP address).
  5. Your IP camera is at the IP address, so it sees the http request (along with the full URL at this point), and is able to respond with the requested resource

Here’s a visual version of the above that I quickly put together:
(tap the right or left side to move through the slides)

DNS by Joshua Lyon
Images (tap to expand if the embed above doesn't work)

Overview

Subdomain Lookup (DNS Request)

Subdomain Response (DNS → IP)

HTTP Request (to camera)

HTTP Response (from camera)

This YouTube video explains how DNS works and might be interesting to you as well.

Interesting. Can you clarify what you mean by ‘video’? Do you mean an MJPEG stream pointing to a local IP?

Where is your MJPEG stream coming from? Directly from the camera (if so, what model) or something like TinyCam?

1 Like

16 posts were split to a new topic: Fire + TinyCam + Fully + Mixed Content

In my case, its the stream coming from tinycam that still isnt working, w/ nip.io.
maybe it needs to come direct from the camera?

No, there’s no such limitation.

I would recommend creating a separate thread and sharing the details of your configuration so we can best assist you.

:page_facing_up: Effective Ways to Seek Help and Troubleshoot

1 Like

this may be a dumb question, but does FKB act as its own browser or leverage default browser app of device? Can it call Firefox?

:point_down:

And no, you can’t have it run the Firefox engine.

1 Like

My FKB just started not loading my local lan images, thanks for the nip.io workaround! Really easy once I got my head around it lol.

I’m on a Kindle with FK, and it does not seem to work, it does work in Chrome though. I assume that is has to do with the SSL/Mixed, even when I change the settings.

Could be… hard to tell without more details. Fully Kiosk uses the ‘webview’ bundled with the system. So if that webview is running version 85 or newer, it would be impacted by the mixed content issue (HTTP image on HTTPS page)… or if it’s running 111 or newer, it would be impacted by the local IP limitation.

Both are discussed in detail in the posts above including workarounds for both.

wanted to update; everything all of a sudden started working, including using nip.io. i didn’t touch it or change anything, and one day it started showing up. i assume something was updated on the browser side.

1 Like