Dashboard Media Tile on Local Network

I’ve tried searching but can’t come up with anything. I have a ST dashboard running on a Fire8 Tablet. I want to media links to my kid’s monthly school lunch menus and I’m not sure how to get it done without a ton of new work every month.

They are hosted on the schools site in PDF form. I don’t think linking to a PDF is going to work smoothly.

What I’d like to do is take screen shots of the monthly pdf and save the JPG in a local network folder on my NAS. Each month I’d save the screenshot as the same file name so no updates required for ST. I’ve tried everything I can think of with no success. I got it to work on Imgur but they are unique file names so I’d need to update the links every time in ST. With this much work, I don’t think I’d keep up with it.

Any ideas?

Hi @Morgan_Young, welcome to the community. Which part didn’t work for you? Accessing the image file from NAS over http link, or the image not loaded in the dashboard? You may want to take a look of this “Mixed Content - Media Not Showing” post if your NAS doesn’t have SSL certificate (access over http instead of https) and you are viewing the dashboard with the media tile on Chrome v85+.

I’ve done the similar thing that I use puppeteer to take screenshot of our local city’s COVID’s chart daily. It runs automatically and saves the file with the same name on my NAS where I created a share link that to be used with http link.

I think this is what I did to create the share link on my QNAP NAS.

1 Like

Thanks for the puppeteer info, that will make things even better once I get this working.

I think my issue is ST reading the image file. I didn’t have the files in a public folder at first but moved them based on the link you provided. This didn’t change anything though.

My QNAP NAS is giving me share links without a file extension, like this: https://****************/share.cgi?ssid=0z28VJE

Are your links similar or are you able to get file.jpg type links?

1 Like

This is how my QNAP file link looks like. I’d guess the open=normal parameter may be required.

1 Like

Got it to work! Yours has the filename after share.cgi, mine wasn’t including that in the links? Weird, but manually changing it worked. Thank you!!