Blue Iris IP Cam Help Needed

Hi,

I am able to see my Blue Iris IP cam video in the Dashboard. However, when I log in on another device (kindle fire) all of my apps work besides my IP cams. Can anyone help me trouble shoot this?

Thanks!

Hi Roger,
It’s sounds the Fire tablet might not be able to connect to the Blue Iris server. Can you verify if your Kindle Fire is in the same network as the Blue Iris server? You can check it by input the Blue Iris camera url in the browser on Fire tablet.

As James mentioned, you might try accessing the Blue Iris mjpg URL directly in your Fire tablet’s browser (eg. outside of SharpTools.io) and double check that the tablet is on the same network as the Blue Iris server.

I usually use the format: http://{blue.iris.ip}:{port}/mjpg/{short_name}

Is that the format you are using?

You may also want to adjust the Blue Iris authentication settings under Web Server → Advanced section → Authentication. I have mine set to "Non-LAN only" which means that I can hit the streams locally without providing any username/password, but if I try to hit it from outside my network, I have to provide the password.

Hey Josh and James,

Thanks for your help. The suggestion Josh gave me (change stream verification to non-LAN only) did the trick. Thanks a million (you both saved me a ton of work and aggravation). My BI video streams are up and running in Sharptools now.

2 Likes

Hi Josh,

I can not see my cameras on the dashboard, on Chrome I use this http://{blue.iris.ip}:{port}/mjpg/{short_name} and I need to type login and password, could you please give some help here.

Is the device you are viewing the dashboard / Blue Iris feeds from on the same network as the Blue Iris server?

I vaguely recall someone else having a similar issue with the ‘Non-LAN Only’ option and they realized they had multiple layers of network gear which was causing Blue Iris to think the viewer device was from a different LAN.

1 Like

Josh, Yesd I am on the Lan< i made test now, enable the Anonymous user on my Blue Iris than the Sharp Dashboard works.

So I “think” I need to add the login and password here http://{blue.iris.ip}:{port}/mjpg/{short_name} but I do not how.

You can find more details from the KB article below. But unfortunately, many browsers including Chrome started blocking embedded username/password in the URL.

I use Blue Iris too, so my dashboards at home are in the same LAN and can access my BI cameras anonymously, and I use Blue Iris app on my cell phone to access it externally with username/password protected.

I never tried this but I think a workaround is to have your external device connect to your LAN via VPN so it can access the BI on LAN anonymously.

As James noted, some modern browsers have begun blocking credentials in the format http://user:pass@resource, but if I remember correctly Blue Iris also accepts the username and password as query string parameters if ‘secure only’ is disabled in Options → Web Server.

http://resource/?user=user&pw=password

eg. http://192.168.1.10:81/mjpg/frontdoor?user=user&pw=password

My Blue Iris instance isn’t up at the moment, but perhaps you could try that. Here’s a few threads referencing the option:

https://ipcamtalk.com/threads/embed-credentials-on-blue-iris-web-server-url.7327/post-74474

https://ipcamtalk.com/threads/blue-iris-urls-for-external-streams.24994/


After re-reading your post, I’m not sure I understand why you want to add the login and password into the URL though? It sounds like if you chose Non-LAN Authentication and the MJPEG stream is showing in your SharpTools dashboard, then you should be good now, right?

Or are you implying that you want to use an ‘external’ URL to Blue Iris so you can access your streams while away from home?

1 Like

I just tried adding the username and password as url query string parameter as @josh mentioned, and it works for me if I have the Use secure session Keys and login page option unchecked in the Web Server -> Advanced page.

Found this in the Blue Iris help doc.

2 Likes

This works well, thank you guys :grin:

http://resource/?user=user&pw=password

2 Likes